Page number field yields "Page numbers" text

I’ve made a terrible mistake! Okay, a mistake, at least.

I bollixed something up while creating a new page style to try to restart page-numbering within a document.

Ever since, every new document I create, and every old document I open, regardless of page style, can’t display actual page numbers – instead I get the text “Page numbers.” Can’t figure out how to get the field to display correctly again.

My questions:
– Has anyone else had this problem?
– Any suggestions of how to fix it, other than reinstalling the program?

I’m using Writer on Windows 7.

Just press Ctrl+F9 (which is probably how you got into this problem). It toggles displaying Field Names.

Alternatively you can go to Tools >Options > Click on LibreOffice Writer on the left panel list, then on View

On the Display options uncheck “Field codes”.

I had this problem and the suggested answer above solved it. Page numbers appear differently according to what is selected after selecting “page”. If next we select “next page” numbers will start with the figure 2 on the first page. If we select previous page numbers start with 0. To start with 1 one should select “page numbers”.