Page Numbers in Index identical to last Page Number

The items in the index I have created all have the same page number which is the number of the last page of the document, whereas each item should have the actual page number in the document. What do I do to correct this?

Also - I deleted a large part of the document to meet your size limitations, then recreated the index and now I see that the entire list of the original first lines is included, although the deleted lines no longer exist in the document?

[Edit - Opaque] Moved original title to details and added a short title.

LO size limitations or your computer memory limitations? Note that for printing, colour or greyscale images normally don’t need to be greater then 300dpi, while for one bit back and white then 600 dpi is normally sufficient.

Have you read Chapter 15 of LO Writer Guide 6.0 which covers indexing?

Thanks, Earnest Al. I read the Chapter 15 and created a new index. Now I have the index entries for the four or five entries I chose with the correct page numbers in the shortened file I created to experiment with the index. Unfortunately, I am still getting all the other items from the original larger document! How can that be, because these other 200 entries do not exist in the shorter document?

Right-click on the index and select Update Index. Are they still there?

If you click View | Field shadings Ctrl+F8, can you see a bunch of index entries somewhere in the text?

If you Ctrl-click on one of the “other 200 entries” where does it take you?

If you hover over one of the “other 200 entries” does it show a tip reading “Alphabetical Index: [word]”

If you delete the Index are the excess entries still there? If they are delete them too. Your index entry markers through the text of your document won’t be affected by deleting the index. When you have done that you can insert a new index.

Thanks Al.
I right click and Update Index and the entries are all there, including the “ghost” entries which do not exist in the document.

Yes - I see the four or five shaded entries throughout the doc.

The “other 200 entries” are in the index - but NOT in the document, so I cannot hover over them…

When I delete the index, the excess entries are not there, because I have deleted 150 pages from the file in order to get the doc size down to the size it could be accepted by AskLibO. The shaded entries are still visible in the doc (which now has no index.)

I insert a new index and the “ghost” entries are back in the index and all of them have the page number of the last page of the document. The shaded entries are in the index together with the ghost entry with the page number of the last page of the doc. So - somehow, the index is “remembering” all the first lines of the poems that have been deleted!!!

How did you create the index first time?

Are you using a concordance file? If so you could right-click, Edit Index and untick the box next to concordance file, Ok out and Update Index.

You might have to attach the document to see what is happening.

[…] items in the index I have created all have the same page number which is the number of the last page of the document [ …] deleted a large part of the document […] Unfortunately, I am still getting all the other items from the original larger document! How can that be,[…]

Without the sample document (which you say you prepared, but if you uploaded it, the link must have been removed from your question), I find only the above info to base a guess on.

My guess (also corresponding to @EarnestAl’s comments, which for some reason I didn’t see at first ; great minds think alike, they say …):

You may have added index entries without first selecting the indexed term in your document. Then, when you delete a word which constitutes an index term the index entry is not deleted with it, and will remain. If the cursor was around the index when you added the entries, they will all be on that page (and an index is commonly found at the end of the doc, which explains why all entries show that page number).

This may also happen if you convert between different data formats. E.g. open with MS Word/WordPerfect, save to a “foreign” format (Word file, RTF). I haven’t seen this particular effect from that, but stranger things have happened at sea …

To determine whether this is the cause:

  • Enable View field shadings
  • Look for a tiny grey vertical bar in a text line just below or above the index. This will be a field with no content to display (or more likely, a couple hundred fields on top of each other).
  • If you see one such grey bar, hover the mouse ponter over it and wait for a badge to pop up.
    Does it display Alphabetical index: <index entry>?

If this analysis does not match with your document or otherwise helps you to resolve your issue, please keep us from guessing. Upload that sample you prepared. I don’t know any way to access your previously uploaded files, so you probably need to upload again.

I did not look at the other replies that came in early this morning, but I looked directly at your latest posting.
Yes, Al. The original file was created from WordPerfect 11 and I copied small sections of the WP document into my new LO file; I had to copy it in small chunks because the conversion process would not handle illustrations.
I found the little grey bar right at the end of the small document (that is the one I reduced in size for my upload to AskLibO) and it displayed “Alphabetical index:”.
I had some difficulty deleting the grey bar and then I tried Ctrl-End and that took the cursor to the rear of the grey bar. then I was able to highlight the spaces beyond the grey bar together with a few spaces in front of it and then Delete the highlighted portion including the grey bar.

I then inserted my Index of First Lines and it worked perfectly!!!

You were a huge help, Al - I spent several hours struggling with this! Thanks a lot - your help is very much appreciated.

Happy to hear that it’s fixed. You could tick answer by keme as it is the same but clearer. Cheers, Al