Pages don't end aligned, why?

When using LibreOffice for wordprocessing, you can use orphan and widow control . But the end result in my file is that all the pages look like they are of different lengths. One page has the text ending 1cm from the bottom. The next has it ending 1.5cm, and so on throughout the document. If I use LibreOffice to produce a PDF to send this book to print, the printed book will look odd, as the last row of text on each pages will always be at a slightly different level to the opposite page. Is there any solution?
I’m using Ubuntu 20, Libre Office 6.1.2
I’ve uploaded most of the file here -as you can see pages 3 and 4 have different lengths due to widow and orphan adjustments.

Document attachment deleted by ajlittoz on OP’s request

@ djwebblibre
What you are probably looking for is a (German) so called norm page (standard page). See this (German) norm page for your download.
Checking the German norm page you may find out that it contains lines (and paragraphs) with no spacing above/below and fixed line spacing. The type writer style is the orientation for this kind of norm page.
LibreOffice: What you can do for standardized equally filled pages is…

  • Use equal spacings.

  • If you have different spacings have a look to register true page spacing (find settings in page style and paragraph style)

  • If you use orphan and widow control you have to enlarge spacings manually, I think (I did not test that).

If your concern is only about alignment of lines on opposite pages and not about the number of lines, there is an automatic solution called “registering”.

Widow and orphan control will always remove a few lines at bottom of pages, this can’t be avoided. Registering forces all lines to be set on a virtual grid. In other words, line spacing is automatically adjusted to sync on this grid.

Two things must be done:

  • configure the page styles
    Don’t bother for cover page style and similar ones where you need full layout freedom. Customise the page styles for the main document text (this could be as low as Default Page Style if you use only this one or the pages styles for the chapters, including first chapter page and left/right pages).
    In the Page tab, check the Use page line-spacing box (this is the new label for Register-true setting of previous releases) and select the reference paragraph style. The Text Body default is usually good.

  • configure the paragraph styles
    For every paragraph style used in the main part where you want to synchronise the lines, check the Activate page line-spacing box in the Indents & Spacing tab (once again this is the new label for this setting as most users didn’t understand Register-true in pre 7.x releases).

This will ensure all lines will be aligned on opposite pages with spacing quantised to cope with the grid. Your pages will still have various spacing at bottom but this will always be a multiple of the grid.

1 Like

I tried that it doubled the size of the document. I think that is because of fixed line spacing. What is the right line spacing for a text at 11.5 pt font? Looking through my email from a publishing company, the company that is going to print the book told me not to set line spacing at “Single”, but go for a fixed 13 or 14pt, as inadequate line spacing would make it difficult to read. I think this may be why I’m having difficulty, as the text could spread out more easily if I had Single line spacing.

Give more “technical” details about your document. How do you style it? Is your “bulk” text in Text Body or Default Paragraph Style? Any line spacing is possible but you must be cautious about the reference.

– I didn’t notice that you had uploaded your document. –

The problem with registering comes probably from the fact that you designed your own Main text paragraph style instead of using built-in Text Body. It doesn’t really matter but this means that Main text should be the reference style in the page styles.

When I do this in First Page and Index, page count increases from 343 to 370 which is tolerable (FYI I have no Linux Libertine, so, a replacement is used which could explain the differences with your own count).

A good idea is to check Activate page line-spacing in Default Paragraph Style so that it propagates implicitly to all other styles (I didn’t notice at first you also use Indented text and I forgot to activate it).

Suggestion: Your paragraphs “Leabhar” and “Caibideal” seem to cover two different “notions” (part and chapter?). You should style them differently, e.g. Heading 1 and Heading 2. This would give you more formatting/lay out freedom.

I’ve added most of the document to my original post. I’ll try what you said. Leabhar and Caibideal (book and chapter in Irish) are both styled Heading 1 in order to be picked up in the Table of Contents generator. Thank you very much for your help.

All Heading n are collected into the TOC. By having two styles, you can format them separately in your text (Heading 1 and Heading 2) in in the TOC (Contents 1 and Contents 2).

You could also use Tools>Chapter Numbering to make Writer number your chapters. Your book looks like a novel, so there is no real point in reorganising chapters and you won’t need auto-renumbering. But think of all the reliability and “safety” you can get from Writer auto features.

I checked your document. Activate register true in your page style. Also: See what @ ajlittoz proposes. Really pretty suitable!

Thank you all for your replies. I don’t want people to think I am not grateful. I’ve been busy proofreading the book. I have register-true’d the Main text, which added 26 pages to the document. But I decided not to register-true the back-matter, which is at 9.5 pt font and not 11.5 pt font, as register-true seemed to add a huge number of pages to the document, being linked to the Main text in some way. The document looks better.

Can I no longer delete the document I uploaded from the original post? Do you have only a certain amount of time to edit a post? I wonder if a moderator can help me by deleting the document I uploaded in post 1. I’m sorry to trouble you.

I think that the site engine allows for modifications only within a rather short time frame for newcomers. Regular contributors progressively acquire higher privileges, among these the ability to edit their posts without limitations.

I removed the link to your document, but the file, though no longer accessible, is probably still somewhere on the server.

Thank you very much!