Pandas extension problem - pandas installer

Good Morning

I tried to install the extension for pandas from
Pandas for LibreOffice » Extensions

After installing the iextension and I restart Libreoffice I get the following in the windows task manager:

LibreOffice (32 bit)
   +--Pandas Installer

and it just remains there.
I am behind a corporate firewell. Any ideas how to resolve this issue?

I am coming in late on this one. However, I am the author of the extension.

I am not sure why exactly why you were having an issue installing but If you got what you need that is great.
Note that there is logging available while the extension is installing. That might help figure out the issue. See the Options of the extension in the Extension Manager.

There is a few things to be aware of that the extension handles automatically. On windows if you are using both 32bit and 64bit LibreOffice then Pandas and Numpy will have conflicts. This is because 32bit and 64bit have different binaries for Pandas and Numpy. The extension Isolates for both 32bit and 64bit to avoid these conflicts. Alos note the LibreOffice on Windows use Embeded Python. So Python is missing a few things including bz2 that Pandas needs. The extension also handles this automatically.

LibreOffice FlatPak on Linux has some big Pip install issues. Although the Zaz-Pip version 1.0.0 or greater might work, I worked with the author and it seems to work. The extension will handle install on FlatPak automatically.

On Mac and also AppImage (Linux) LibreOffice is using an embed python. This means that any python packages installed into LibreOffice that need binaries (Pandas, Numpy, etc) will not work. The extension automatically fixes this issue, also Zaz-pip has been patched to work in these cases as well.

remove or kill libreoffice via task-manager, and after that remove anything belonging to Ooodev, pandas ect. in the respective …site-packages folder or better remove the whole site-packages folder.

instead the normal apso.oxt install this branch of apso.oxt with pip

It provides you with a clean pip-installer-dialog with which you can install any third-party-package you like … and not all the additional stuff which @vlb thinks you should use mandatory!

I will accept this as a solution, however the corporate firewall blocks the link for the suggested apso.oxt!!!

Thats weird… so it should block any link to extensions, can you visit the the master-branch of apso.oxt

which OS do you use?

In answering your question for the OS. It’s W10

OK installed this on both my home windows and linux workstations. Now i remember why I downgraded to 1.3.0 in the first place.

I got this error again:

Traceback (most recent call last):
  File "C:\Users\TOSHIBA\AppData\Roaming\LibreOffice\4\user\uno_packages\cache\uno_packages\lu11376e7ru.tmp_\apso.oxt\python\", line 921, in exec_edit
    url = tempfiles[node.uri]
KeyError: ''

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "C:\Users\TOSHIBA\AppData\Roaming\LibreOffice\4\user\uno_packages\cache\uno_packages\lu11376e7ru.tmp_\apso.oxt\python\", line 974, in _create_tempfile
  File "C:\Users\TOSHIBA\AppData\Roaming\LibreOffice\4\user\uno_packages\cache\uno_packages\lu11376e7ru.tmp_\apso.oxt\python\", line 1016, in adddoceventlistener
    doc_id = "{}:/{}/".format(self.DOC_PROTOCOL, doc.RuntimeUID)
AttributeError: RuntimeUID

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "C:\Users\TOSHIBA\AppData\Roaming\LibreOffice\4\user\uno_packages\cache\uno_packages\lu11376e7ru.tmp_\apso.oxt\python\", line 926, in exec_edit
    url = self._create_tempfile(node)
  File "C:\Users\TOSHIBA\AppData\Roaming\LibreOffice\4\user\uno_packages\cache\uno_packages\lu11376e7ru.tmp_\apso.oxt\python\", line 988, in _create_tempfile
    raise ErrorAsMessage("_create_tempfile\n\n"+str(e))
uno_component.ErrorAsMessage: _create_tempfile


May you explain why there are such bombastic huge RuntimeUIDs on your system??

Not only you, but there was already a topic by @ztminhas about this miracle!

A blind attempt to fix:
Another possibility would be a use-after-free, but that definitely can’t be fixed without a reproducing scenario (I don’t repro the original problem here).

This only happens when trying to access the python scripts embedded in the document

of course … otherwise the RuntimeUID isnt needed

Does the fact that Apso 1.3.0 does not have an error while versions beyond that have errors mean anything?

I think it doesn’t. Basically, a newer version of APSO added a document event listener. So it seems to simply hit/expose a pre-existing problem.