Paper format size is different when printing

After choosing/making a paper size of “user” 3 x 5 inches & composing the text to fit into it, when printing, it always ignores my previously selected paper size & shows “3.87 in (#8 (Monarch) Envelope x 7.50 in”.
Have tried creating a template with my custom “user” size & it is still ignored when actually printing, tho is shows ok in print preview.
Also tried the German “FreeOffice” & a couple other such suites. All exhibit the same phenomenon. Looks like the historical code base is the same for all & thus, it has been carried across the several free office suites. Maybe it’s buried deep in code?
The previously gratis WPS does a print preview & actual print ok - but some say their EULA says, ~, “if created with our product, we then own your work.”
Hope springs eternal that there is some work around, since am using the latest update,

The default action is, that LibreOffice takes the best fit out of the formats, which the printer supports, according the informations in the printer driver. To use a user format you need two steps in the printing dialog:

  1. First click on Properties on the tab General. That opens the printer settings dialog of your printer. In that dialog choose the paper size you actually want to use, not the dimensions of your document.
  2. Go to tab Options and check the option Use only paper size from printer preferences.

In case you want to print two document pages on one sheet of paper or similar, you find the settings in tab Page Layout.

The preview should be correct. Please examine the measure lines in the preview.

The latest update is version 5.1.5.

I assume you have 3 x 5 inch paper you want to print on. A lot of printers allow you to set a user size. In the printer properties tab mentioned by @Regina look if there is a user size for the paper. If so set it to 3 x 5 inches.