Pasting formulas from Math to Writer does not work

I’m writing a document, where formulas from Math are very important. I had success copy/pasting a couple of times (although it’s really tedious), but now nothing works.

In my document, I do the following:
1: “Insert” > “Object” > “Formula”
2: A Math window opens. I open the file with the formula.
3: “Edit” > “Select All” > “Copy”
4: Back to the Writer window. “Edit” > “Paste”
And then… nothing.

Perhaps my way of doing this is wrong, then please educate me. It was the only intuitive way that I found.
I need help here. The only other option I see is screenshot and copy as .png.

EDIT (22.01.2021, 22:14): Thank You for your answers/comments. I see that I stated my question imprecisely.
The situation is, that I’ve created some quite complex formulas in Math, each formula saved as a single .odf file. I want to integrate these formulas in my Writer document.
In the meantime, I’ve managed to get this to work:

Writer: Insert - Object - Formula
Math opens.
File - Recent Documents, open the relevant file (the normal File - Open is greyed out!)
A new instance of Math opens.
Copy from the lower screen of Math
Paste into the Writer document.
Formula is now there.
There must be an easier way, but I don’t see it. Or I’m too dumb.

(Slightly edited by @Lupp according to the comments below.)

Why are you copying?

Click in Writer where you want your formula. Create your formula, click back in Writer and the formula is there. Double click the formula to edit it if needed

Even easier, type out the formula commands in Writer, select them, click Insert > Object > Formula

Also if you customise your toolbar you can add an Insert formula icon

Do you ( @ml9104 ) feel sure the many empty lines are helpful?

“Do you ( @ml9104 ) feel sure the many empty lines are helpful?”
No, and I don’t like it either.
But the fact is, that if you use single line breaks on this site, they disappear and everything is bundled into one paragraph.
The only solution I’ve found is to use double line breaks, that then astoundingly behave as double line breaks.

EDIT: Well, my comment actually just demonstrated the issue. It was nicely formatted with single line breaks, and now looks like garbage from a teenager’s Smartphone.

@ml9104: I reopened the question because I doubt it is a duplicate.

On this site, the way to tell the problem is solved is to click (only once, even if seemingly nothing happens!) on the gray checkmark at left of correct answer. This will turn the mark green after some time.

Considering your karma, you may also upvote the answer by clicking on ^ above the answer scoring if you think it is useful (to make differences between answers).

After that, you can close the question, but this is not mandatory in case you consider the answers can still be improved. Take care to select a relevant reason from the drop down menu.

@ml9104: Again about empty lines:
The editor of this side insist on two prefixed spaces to a hard line break to make it work.
Concerning comments it doesn’t accept empty lines anyway, if I have it rightly.
Assuming your consent I will edit your question slightly now to giv an example.

Thanks for the tip, I’ll try to keep that in mind.
And Thanks for beautifying my post.
Ha! It works!

There is not need to copy and paste.

Once you’re satisfied with your formula, click in the upper window pane where you see part of your document (with the result of formula formatting). You’re back in Writer.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

Users of Writer wanting to insert formulas using Math into their texts and
a- needing many, but only simple formulas or
b- knowing the keywords and the special charcters of Math, and their semantics well

may also be interested in this thread, my answer there (edited!) and in the comments following it.

To insert a formula stored as an idependent document, don’t use
>Insert>Object>Formula, but
>Inset>Object>OLE Object...>>enable Create from file>>>enter the filename or browse the file.
Make sure to only consciously check one of the additional options.

Now THAT works reliably. Thank You.