PDF checkbox not displaying if checked

Recent upgrade to Ubuntu 22.04. I believe LibreOffice also updated at that time, and now my PDF documents no longer show if “check box” has been checked. Am I doing something wrong, or is there a bug in new program?

EDIT (additional information transferred from comment by ajlittoz)

I am using buntu 22.04.1 LTS and LibreOffice 7.3.5.2
I have created a form with Writer and saved it in PDF.
The form in writer works working fine with all the boxes working, including the checkbox.
When opening the corresponding pdf form with DocumentViewer, all the boxes work fine, except the checkboxes, with the ticks not showing.
I assume there is an issue somewhere ;=))
Note that I find the cration of a form under LibreOffice amazingly easy

Which LO version? Which “check box”? What (How) are you doing?

If you expect some help, first help us to understand your problem. We can spy over your shoulder to see what you are trying to do and we aren’t in your head to guess your goal.

Please edit your question to make it more explicit

Hi.
I am using buntu 22.04.1 LTS and LibreOffice 7.3.5.2
I have created a form with Writer and saved it in PDF.
The form in writer works working fine with all the boxes working, including the checkbox.
When opening the corresponding pdf form with DocumentViewer, all the boxes work fine, except the checkboxes, with the ticks not showing.
I assume there is an issue somewhere ;=))
Note that I find the cration of a form under LibreOffice amazingly easy

I’ve got the same problem… seems it’s not been solved within the last three months…

Export as PDF
Archive (PDF/A, ISO 19005
PDF/A version: PDF/A-2b

There is a bug which affects the color of the content entered in the form. I don’t know how to reproduce it exactly but if you have changed something and you havent set a particular color there is a chance, that the input color is switched to “white”. The boxes are working but you cannot see it.

  • In the document open the properties of the checkbox form element
  • Go to “Font” > “Font Effect”
  • Choose another color than the selected (even if it is “black” - it is not set really to black at the moment) , maybe Dark Grey 4
  • Save and export as usual to PDF
  • Optional: Go back and change the color to black (Dark Grey was black enough for though)

You should see the crossed checkboxed again now. Takes me a whole day and a lot of breath to get this…