pdf file size is too smaller after --convert-to

After spent many days of struggling, finally I built libreoffcie- on Arch linux.

I run the command line on new built software: soffice --headless --convert-to pdf my.docx
(here my.docx is a regular English document with size 19K)

my.pdf has been created successfully. but the display in Adobe Reader looks strange: The structure of pdf resembles original docx format. but all characters in pdf are display as [], in Adobe Reader.

I did the compare with the libreoffice installed on Mac. Here is the summary:

Original file size (.docx) 19K

pdf size after using software built on linux box: 8.5K

pdf size after using software installed on Mac: 98K

You see that the size after converting using new built was much smaller that the one built from installed software.

Any idea how this happened or how to debug the issue?

Thanks ahead for any help

I tried to convert from .docx to txt or html format. They all succeeded without issue.

I tried with different filter for pdf convert: ./soffice --headless --convert-to pdf:writer_web_pdf_Export my.docx
Result was the same.

it seemed that import a docx isn’t issue and could convert to other format. but not pdf format.648

does it convert well when using it via gui?