Permission needed to open .doc file in LibreOffice

I got a new computer recently and am currently using Windows 8.1, with version of LibreOffice. I don’t recall having this issue on my old laptop, but I’m not sure if it’s a Windows 8.1 problem, a LibreOffice setting/problem, or just a setting that I need to change on my computer.

Opening odt files, fine. Not a problem. When I try to open a new doc file (I edit manuscripts, and most are sent as .doc files.), just by double clicking it, it pops up a message asking if I want to open the file, with an option to check or uncheck the “Always ask before opening this file.” It’s like that when I open up a new .doc file. If I have LO open already and open file through there, it opens without a message. But if I just double click on the .doc file to open it, it gives me that message box.

It’s not a huge problem, but I would LOVE to be able to just double click to open the file like I do for .odt files.

Anyone have a suggestion?

Go to Tools > Options > Load/Save > Microsoft Office and check all fields like:

Load/Save → Microsoft Office
“specifies the settings for importing and exporting Microsoft Office OLE objects”.

See also this screenshot (LO 4.2.0).

Thanks… I looked at those, and all are checked already. :frowning:

@JenRar - Then I am afraid it is a Windows problem. A last attempt in LibO would be deleting User profile and make a new one. For how to, please have a look at: