Permission password set to no copying but it still copies

Hi Thanks for LibreOffice
Using Mac, after setting permission to not copy, when I leave ‘enable coping’ box uncheced - after encrypting I can ‘duplicate’ and make a copy.
Please advise
Many thanks

I set the permission password and selected
Printing not permitted
Changes not permitted
Content (unselected enable copying of content)
Checked enable text access for accessibility tools
The document will not print (great)

But I duplicate the page in mac and it copies. (not great)
Please advise how to prevent duplication/copy

Many thanks