Please help. LibreCalc is using commas over points for the decimal place

LibreCalc is using commas over points for the decimal place. I have checked settings and under Language, “Decimal Separator Key - Same as Local Setting” is checked and My regional settings have the point as the setting on both Number and Currency. What could be my next best option to remedy this situation?

My regional settings

which? and set where?

Search this site. Similar questions have been asked and answered many times.

@Mike2. Control Panel → Clock and Region → Region → Additional Settings

Try changing the Locale setting via Tools, Options and Language Settings.
(It may be that this is a different route to the setting to the ones you have already tried.)

That’s exactly where I changed it and it made no difference

Thanks for helping me out. I changed the “Locale Setting” on LibreCalc from “English - South Africa” to “English - Zambia” and it did the trick

Fwiw, the official decimal separator in South Africa is the comma, this was adjusted for LibreOffice 6.2, see tdf#119613.