Possible Bug: Can't Fully Delete Comment When Record Track Changes is on

I may have stumbled into a bug on LibreOffice Writer (v (x64), Windows). I had record track changes turned on as I edited and made comments on a document (saved in Word, docx (2007-365) format). I added comments, saved document, and closed it.

Later I opened it back up* to finish working on it and decided to delete a comment. When I did so, instead of than the comment deleting, an “X” was placed through the comment, it didn’t just delete or go away. I saved and re-opened thinking it would be gone but the comment was still there and fully restored (without the “X” through it and fully editable along with the option to delete the comment again - which would also result the X and ‘incomplete’ deletion).

I tried ‘deleting’ the comment again, got the X through it and then decided to try to delete the comment’s text but got an error that it was “Read Only Content” and “Write-protected content cannot be changed.”

I realized that somehow the the comments are becoming part of the ‘track changes’ tracking. I turned off the record track changes and then deleted the comment and that worked (comment disappeared).

It appears that if you comment while track changes is on, comments after a document is saved-closed-reopened are somehow seen by ‘track changes’ as part of the document text that is tracked/protected which causes an error in deleting a comment. This error is also limited to deleting, comment text can still be edited.

*I verified that the bug only occurs when a saved document is opened later. Comments made during the current editing session can be deleted (even if you save the document - the key is if you save and close, then the next time you open, the prior comments cannot be deleted until you turn off track changes). I also tried some suggestions here but they didn’t fix it: Read only content cannot be changed, no modifications will be accepted

Let me know if this was an intended feature, there’s a setting I need to change or if this is a bug. Thanks!

1 Like

You say you save as .docx. This involves two conversions: one for saving, one for loading. The conversions to/from foreign formats may bring in their problems, aggravated by the fact that this format specification is not public, leading to approximation.

Does your difficulty persist if you save .odt, the native format?

Answer either editing your question but making it distinctive with some prefix like “EDIT date” or “ANSWER to question”, or using a comment. Answers are reserved for solutions.

@ajlittoz is quite right; yet, if you discover that this issue does not happen with native format, please still don’t forget to file this as a bug (well, please do it in any case: be it DOCX-specific or not).

On the other hand, it could be something like tdf#130838 (but specific to Writer); even if that’s intended behaviour, missing documentation on that is still a bug (please file it, as mentioned).

I just want to bump this topic, since I have encountered this problem now myself. The document which has this problem has been edited on 3 different installations of K/Ubuntu with LibreOffice, the format has always been .odt and has not been changed.
If a comment is deleted when track changes are on, it will get crossed out. If the document is re-opened, the comment stays crossed out, and cannot be modified anymore. The only option which I have is to “resolve”, which changes nothing, or to accept all comments of the author.

It’s a tad annoying.

I just want to bump this topic

… for which purpose? This is not a place to file bug reports. The advise to file it properly was already given. What else do you expect here on user-to-user help site?

1 Like

Here’s a workaround if you have one of those comments with an X through it (which I will call a “zombie comment”) and you want to delete the comment completely, without touching other comments:

  1. Right-click on the main text where the zombie comment is pointing > Reject Change (Since the comment may point only at a very small piece of main text, you may have to position your cursor very precisely in order to see “Reject Change” in the right-click menu.) Now the zombie comment is back to a regular comment.
  2. Edit > Track changes > Uncheck “Record” (stop tracking changes)
  3. Click the drop-down arrow under the comment itself > Delete Comment
  4. Edit > Track changes > Check “Record” (resume tracking changes)