possible bug in (vector <T> too long)

I just upgraded LO to (English) and I’m hitting some weird errors trying to open plain text files (.sql) from Firefox 36.0.4. I am running Windows 7, 64 bit. I don’t use LO for anything fancier than text editing and simple spreadsheets.

I click a link in Firefox to open up a .sql file … dialog window comes up asking what i want to do with the file … i say i want to open it with LO Writer. So far so good. Then LO pops up a dialog window asking me to select a character set to “import DBase files”. Hmmm. I’m not using Base, so I don’t know why that happened. I tried various Western Europe character sets from the list (i’m in the U.S.) but all of them simply result in a “fatal error” message coming up which says “Vector too long”. The text file never opens.

If I go directly into LO Writer and open files from there, it works fine. Downgrading back to 4.2! Thanks for any help which can be offered.

Just some additional information. I downgraded to 4.2 and tried to do the same simple operation. I’m getting the same error in 4.2 as well! I guess I will use Notepad or whatnot to open files from Firefox. I thought I had done this previously with LO but must have been mistaken.