Possible bugs - calc

There are two issues that might be bugs, otherwise please let me know how to solve them.
I use multiple .xlsx files, not sure if this is a reasun (maybe support for those is not so good)

  1. Constant refreshes
    Window with file open refreshes every now and then, I did not timed it but it’s rather frequent (every few minutes).
    Visibly you can see bottom of window progress bar, just like when saving, but this refresh does not save file…
    When I work on file, and have for example range selected and window refreshes before I select what to do on that range, then selection is lost (eg. select cells and want to set format).
    I noticed this with all files, usually I have multiple open at once.

  2. Issue with Data Validation when file opened.
    When I open file, I have to select each data validation and re-apply ‘sort entries ascending’.
    First I thought maybe I did not saved, but I tested multiple times, each time I reapply sorting, save, close and open file, it is gone…

Version: (x86) / LibreOffice Community
Build ID: 56f7684011345957bbf33a7ee678afaf4d2ba333
CPU threads: 8; OS: Windows 10.0 Build 19045; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_GB); UI: en-US
Calc: CL threaded

  1. may be a result of the timing of Save AutoRecovery information every… as set in Tools | Options | Load/Save | General.

    If you are on a Mac that will be LibreOffice | Preferences, rather than Tools | Options.

  2. See if saving in native format - .ods - makes a difference.

In future, please include information on your OS and LibreOffice version with your question.

Thanks, will see if 1. will make difference, not sure if I’m yet ready to change all my work to .ods, but will try making copy and see if there is difference. Also updated post with versions.

1 Like
    • yes, you are right, Save AutoRecovery causes it, i tested it by changing time in options and timiming refreshes since making unsaved change.
      I still think i’ts a bug, as Save AutoRecovery should not impact working on spreadsheet. As of now it is disturbing when actively working and making changes in spreadheet.
    • saving as .ods solves issue
      However I need to test many things in my spreadheets before switching my work from .xlsx files.
      Possible bug also, unless it’s a .xlsx limitation in some way.

There is also weird grid over my spreadsheet when saved as .ods, just in one, first sheet in document… do you know what it is and how to get rid of it? Seems like this grid is not based on number of columns but rather actual space they take - as I have varied width columns and spacing of this grid is kinda uniform.


Should I mark my post as solved or wait for someone to use it for making bug report? (If solved, they might not see it)

Without seeing the actual spreadsheet I’ll take a (wild) guess that the dotted lines show the border of printable areas based on maybe the current page settings or any print ranges in the document.

The someone would be you. How to report bugs. Although I’d guess that 2 is a result of the capabilities of .xlsx format. Someone with more knowledge than I may confirm this.

ok thanks a lot

It is worth remembering that Calc will convert your spreadsheet on Open and convert it to xlsx on Save, so you will have two conversions every time. Multiple conversions can lead to errors as there are areas where there is not a complete correspondence.

If Calc can render the spreadsheet correctly as xlsx then it can render it correctly as .ods; the converse is not necessarily true as the xlsx format might not support some Calc features and those features will not be included in the saved file. Note that the same applies to Excel if it is not saving in its native format.

1 Like

Indded, it was Options → LibreOffice Calc → View → Page breaks

Maybe this is the page break view. Unselect the option to hide it.