Possible to have chapter numbering different from header numbering

I have a master-sub document and when I number the chapters using the chapter numbering tools, the index reflects the same numbering pattern.

I would like the index to not show the text I use before or after the H1, H2 and H3 chapter, section and sub-section numbers, but rather just the numbering.

Dunno if I made this clear or not, but am hoping there is a method. Can anyone help?


So you have, like, “Chapter 1 A journey of a thousand miles begins with a single step”, where text in italics is set in the Chapter numbering options and bold numbering is the level numbering. But you want only the number in the TOC, and not the preceding text. That doesn’t seem to be possible.

I would like “A journey of a thousand miles begins with a single step” to appear in the TOC, and “Chapter1 A journey of a thousand miles begins with a single step” to appear as the Chapter Title.

Don’t see where it is possible, but am hoping someone here might know of a way.

This can be configured very easily.

When you Insert>TOC & Index>TOC, Index or Bibliography or, equivalently on an existing TOC when right-clicking and Edit Index, go to the Entries tab.

You can describe in Structure & Formatting what you want in the TOC entry lines. The chapter number (what comes from Tools>Chapter Numbering, i.e. the number and other decorators/separators) is coded as E#. Click on it and press Del.

Repeat for every level you want to customize.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

Seems simple enough, except that I do not see a Del button when I click on the E# button. I have even tried the Delete key on my keyboard. Can you guide me further?

There is no such button. I meant the Del key on the keyboard. Don’t forget to click first on E# to select it.

That worked. Apparently I did not hit the Del key correctly when I tested it. Thanks, many times over.