PostgreSQL REGEXP_MATCHES black cells bug in libreoffice base?

Hello everyone.

First of all, important info: Mac OS X Mojave 10.14.3, LibreOffice

I am connected directly to PostgreSQL (Version 12.6) on LibreOffice Base, and I have this query:

SELECT “product_name”,
REGEXP_MATCHES( “product_name”, ‘[[:digit:]]’ )
FROM “mag”

For the first column, everything is fine, but the REGEXP_MATCHES column is causing issues. All the cells are completely black.

I tried the same for MariaDB 10.5.9 (direct connection with LibreOffice Base) with the same query:

select Product_Name,
from tienda

and I have no issues in MariaDB.

I looked around online a bit by typing “Black cells”, but I have had no luck finding anything.

Has anybody had a similar issue?

The data I am querying is the Sample Superstore csv file used in the “Tableau” software quite often (for those who are curious): 2019 Superstore - dataset by annjackson |


Using LO Alpha on Ubuntu 20.04 Mate with PostgreSQL 12.x and SDBC connection, had no issues. Did use a different set of data as I do not want to sign up for something else I don’t use.

Hello Ratslinger.
Hmm, not sure what’s going on in this case. I will have to look into this more. Maybe using the “Connect directly” option causes issues. No idea.

Understandable about wanting to avoid signing up.

Where do you usually find the alpha versions? I couldn’t find anywhere.


Just tried with LO v7.1.1.2 and a different PostgreSQL database and table. Again no issues. Again on Ubuntu 20.04 Mate.

FYI, alpha version can be found in ‘Daily’ builds under master → Index of /daily/

I will try with the Alpha version (also curious to use it). It would be interesting.
Thanks for showing the index of these versions.

Just used on Mac. Same issue. I’ll have to look into it a bit more.

Tried with JDBC connector and REGEXP_MATCHES column is not black but it is empty. Seems at least in this case it is a bug. Used LO v7.1.1.2

May try ODBC a bit later.


It’s later. Tried ODBC. Worse than JDBC. has many rows but no data can be seen in query or on a form.

Only SDBC worked on Ubuntu 20.04

Edit #2:

While SDBC and JDBC each returned 184 records on my test, ODBC returned 3040 records for the same query - same count as the records in the table. Further problem with ODBC.