Preventing text boxes changing apparent size on linux?

I am working on a presentation using LO on WIndows 8.1. I will giving this presentation on my laptop, which runs Arch Linux, with LO

Everything works fine between the two, except for some reason, there are extra lines that appear at the bottom of my text boxes when I open the file on my Linux machine, which messes up the formatting. They are not actual line breaks, but more like just extra space at the bottom of the box. Oddly, the box sizes (in inches) are identical in both files, perhaps pointing to a font rendering problem? The file also looks normal when viewing through a Windows 7 VM on the laptop, so it’s definitely a Linux problem. The following images illustrate the problem.

(I apologize, but I do not have enough karma to upload images, so links to imgur will have to do)

On Windows (normal):

On Linux (problem):

I also tried switching the font to Arial (instead of Calibri, as it is now), and it did not make a difference.

Any ideas why this might be happening, or how to prevent/fix it?

Edit: Example .odp file showing the problem is here:

(Edit: activated screenshots -AK)

This appears to be an issue with the “Calibri” font. Switching to an open font like “Lato” removes the problem.

I am not sure why switching to Arial last night didn’t work, but it did when I tried this morning.

As already pointed out - the problem is in the font used. Calibri is a Windows-only font, but LO (as from TDF) offers Carlito font family as metrically equivalent substitution. For Arial and Times New Roman, the Liberation fonts offer that metrically equivalent replacement.

I don’t see the package from Archlinux installing the Carlito fonts. only lists the opensymbol font in its filelist, and the liberation fonts only as a build time dependency.

So installing should solve the problem, at least minimize it so you likely won’t notice a difference. Switching to Carlito directly of course minimizes the differences even more :slight_smile:

(you can see what font is actually used by exporting to PDF and view the properties of the created file in your PDF viewer)

Hmm, I actually tried using Carlito from the infinality bundle of fonts (on Arch), but that caused the same problem. I installed on Windows and Linux, and switched all my fonts, but it still persisted. Perhaps because of its “metric equivalence”? Regardless, switching fonts to something else works well enough for me. I’ll accept your answer :slight_smile: