preview in browser not working

I have a fresh install of Ubuntu 18.04.3 LTS and Libreoffice (the latest in the repository). When I try to do File->Preview in Web Browser, nothing at all happens in Calc or Writer.

I have firefox and qutebrower and falkon installed and my $BROWSER environmental variable is set to qutebrower (I tried setting it to firefox and still nothing worked).

I have tried “$sudo update-alternatives --config x-www-browser”, selecting firefox, qutebrowser, and falkon. None of this worked either.

I only ever use calc for simple spreadsheets, so I don’t really have any experience with it in terms of its settings. I poked around in Tools->Options->Load/Save->HTML Compatability, but nothing there seemed to help.

Which repository are you using? Asking because no repository known to me still has as latest. Ubuntu 18.04 still installs 6.0.7 by default, if you don’t define a PPA and PPA for 6.2 installs 6.2.8 and PPA for 6.3 install (or may be in the meantime) - or are you some snap release?

What is your default web application when calling gnome-control-center default-apps ? (I’m not aware of an environment variable BROWSER having any effect on which web application is being called by using Preview in Web Browser).

On my test system using

  • sudo add-apt-repository ppa:libreoffice/libreoffice-6-2 (add 6.2 PPA launchpad repository)
  • sudo apt install libreoffice (installs - as per time of writing this comment)
  • Firefox defined in gnome-control-center default-apps

makes File -> Preview in Web Browser working