Print from Impress

I created a single slide in Impress, but when I try to print it, only about the bottom 1/4 of the slide shows on the preview. The image in the left pane looks fine; it’s in landscape mode, but when I print it out, it’s in portrait mode; if I could get it to print in landscape mode, I think the entire slide would print properly.

I’ve tried shutting the program down and restarting it, same issue. I’ve also tried creating a PDF and printing that, which predictably prints exactly what shows in the print preview.

I’m connected to a wireless Brother printer, but I don’t see the options there that I normally do to choose landscape or portrait. The only thing that seems to work is to take a screen shot and paste it into a word processing page, and print that.

Choose menu File>Print.

In the Dialog choose Paper size “A4” and Alignment “automatic”.

Hmmm, I wonder if it’s my old Brother printer (2013!)?

That’s not at all what I see from File>Print. I should have said I’m on a Mac, Catalina. I can’t seem to paste the image of what I see (like you did!) and don’t see an option to attach a file.

Thanks for trying though! :wink:

Maybe check Brother to see if there is a newer driver for your printer.

But the “Print” dialog here depends on LibreOffice.

Therefore you should install a new LibreOffice version.

Download LibreOffice

I might have the same issue.

Since a recent update, MacOS LibreOffice Impress is missing the function to set landscape/portrait in the File > Print dialog and its sub-menus.

All slides are set to landscape but are printed in portrait by a Brother HL-5470DW printer. MacOS 11.5.1, LibreOffice, Brother Driver Version 2.0.

Update: Printer model and driver is not relevant. An HP printer exhibits the same issue.

Misery loves company, I guess. Seems like this software now being programmed by Microsoft - Nobody programs for anyone on a Mac anymore. But thanks for letting me know I’m not alone.

I had a devil of a time logging in to reply. I had saved my login credentials in my password keeper. It worked when I posted the question, but NOW it doesn’t recognize my credentials, even though it was able to use my user name and email let me know that you posted to this thread. I was able to start A NEW account using the same email account and it didn’t complain about two accounts with the same email address. Sheesh.

In the screenshot, what does the More button next to LibreOffice Impress do?