Print Grid Adds BLANK Column

I have a Calc spreadsheet that automatically ADDS a BLANK Column when I print. I have no data in that column and it looks bad. I.E., I have data in columns A B C D E and when I go to print it using GRID, it prints A B C D E F with F having no data.
I’ve tried deleting column F in the spreadsheet, but the print keeps printing it. I’ve tried deleting multiple blank columns to the right, like F through AA and it still prints an extra column. I tried adding a new spreadsheet from scratch, and columns A - E work for a while, but after working with the spreadsheet for a while, there comes the extra print column.
It’s driving me crazy.
I searched for a bunch of possible words but have found nothing. ANY ideas out there?

Hi. In the menu click Format | Print Ranges | Edit in the dialog window that opens under Print Range there is a button at the end with a Tooltip that says Shrink. Click on that and and the dialog will be replaced by a smaller on. Select in your sheet those cells that you want to include in your printing, the field will populate with the range of your selection. When you are happy click the button at the end and you will be returned to the Edit Print Ranges again where you can alter rows or columns to repeat. When satisfied, click OK.

Click File | Print Preview and you will see just the cells that you selected. Cheers, Al

Earnest Al,
Thank you for your quick and accurate answer. This worked perfectly. I’m wondering if you know why this would be necessary? Why does the software (at some point) add that extra useless column to the print?

Why does the software (at some point) add that extra useless column to the print?

Probably nobody can tell, without having a sample file which shows the artifact.

I can reproduce the effetcs you saw by inserting a transparent Drawing object next to a range, or presumably other objects. If it is achored to the page then deleting the column will have no effect.

If you open Navigator (image of a compass in the sidebar), if any of the headings under Sheet are not greyed out (greying since 6.4 I think) then you have at least one of those objects in your spreadsheet. Double-clicking on a listed object in Navigator will select it and you can then delete or do whatever you want with it. Happy days