Print-time page override

Set-up environment context: I am running

  • Linux Mint 17.3 64-bit
  • The document mentioned below is a collection of 26 ODT chapter files congregated into an ODM file. All files are created from the same template file.
  • The behavior described below holds true whether the LO version is 4.2.x or 5.1.x

I have created the camera-ready copy of a 6-inch by 9-inch book in LO Writer. The page styles within the template file are all clearly set to 6x9, and this is how Writer displays the document in WYSIWYG. However, on the print menu, Writer overrides the set page size with C5 Envelope size (6.375 inches by 9.01 inches), showing this size in the print dialog’s preview. This is true no matter which installed printer I use (the main one is an HP LJ 4250). This frustrating behavior holds true even if I print to PDF (using a CUPS PDF printer) or if I export to PDF.

Within Printer Profiles, the page size option is grayed out and unavailable.

I have tried several different fixes, including:

  • Uninstalling and reinstalling LO
  • Updating to the latest version of LO
  • Booting from a clean USB stick using Ubuntu 16.04 64-bit
  • Reinstalling various printer drivers
  • Checking the entire “chain” of hardware (switch, cables, etc.) between the laptop and printer – even swapped out the printer’s JetDirect 600N card for another one
  • Printing 6x9 pages (newly created) from various other computers in the house and attempting to print from those machines (all LM 17.3, except for one Ubuntu 14.04 machine which does duty as our music server)
  • Creating from scratch a new version of the template file and its page styles.

The results never vary – Writer always overrides the 6x9-inch size with C5.

Any help on this problem would be greatly appreciated. Thanks.

Forgot to add that I also renamed the /user folder, allowing LO to create a new version. It had no effect on the problem being discussed.

For what it’s worth: I also bumped into this kind of problem to print unusual envelopes and I solved it in an usatisfactory way. I think this is not an LO issue but a combination of OS/print engine/driver issue.

Apparently, the user custom page size is converted at print-time to the nearest known “hardware” page size (here hardware means one of the choices offered by the driver, which may not match your available tray sizes). When the printer receives the print file and its tray is not the requested size, the print file is aligned in some way with the paper sheet (from the user point of view, this conversion is unpredictable). As a consequence, text is not always printed where you expect it.

I solved it by using in Page style my tray paper size and defining margins so that my envelope is laterally centered (my tray has mechanically linked sliders which center smaller sheets) and edge-aligned with the paper top edge. Margins are set at the envelope size or smaller to include non-printing areas.

This works as long as the to-be-printed-on paper is smaller the the tray.

Note: my trick won’t work for duplex printing since the non-standard sized sheet (from the tray point of view) will not be correctly guided inside the duplex mechanism and will likely cause jamming).

Hi, Ajlittoz, and thanks once again for tackling one of my problems. You must be right about the OS (Linux in my case). This same problem even affects Writer on a newly installed Raspbian OS on a Raspberry Pi 3 B. Fiddling with the page style has no effect on my target “printer,” which is PDF output (via export or print). Why would Writer default to a pre-determined page size on digitial copy?!

I think my workaround will be to pass the project off to Writer in a Win7 virtual machine. Tests show me that the book will print to the same printer (or PDF) just fine, and there are many more options available under Print Properties. I’m not one to criticize open-source developers – they’ve given us amazing, wonderful software. But I’d love to know if they ran into a roadblock implementing printing in Linux, or if this area of LO under Linux was left half baked.