Print to file option gone from print dialog after update

Linux Mint 17.3. LibreOffice update to Version: and now the print to file option is gone from the print dialog box and is missing as a permanent option. I use the feature a lot and would like to return it.

Why would you update to a version which is over 3 years old - December 2014?

Are you sure it is missing? The dialog opens initially with the default printer. The item “print to file” is the first one in the list, perhaps you have to scroll up in the list? In version 6.0 the item still exists, at least for Windows.

I know where the “print to file” item is — or, rather, was and is supposed to be.

I’m running LibreOffice 5.2 under Ubuntu 16.04. I did not do an upgrade, but I had to rework my printer settings to get my printer working again. That was yesterday.

Today, when I went to a LibreOffice application, the “print to file” item was gone. It appears to be gone on all the LibreOffice applications (Calc, Writer, Draw, …) but it is still present on other applications (gedit, FireFox, Thunderbird, …)


I just tried poking around. Tools->Options->LibreOffice->Print has boxes for “Printer” and “Print to File”, but changing the settings under that didn’t help…

Then, I looked at Tools->Options->LibreOffice->General. There’s a category for Print Dialogues and a box for “Use LibreOffice dialogues”. Somehow, it was checked.

I unchecked it and Voila! the “print to file” item reappeared.

Problem solved. (Only, I don’t understand why the LibreOffice dialogues don’t support “print to file”. But that’s another topic…)