Printer connection message every time I open a document in calc


Every time I open a saved spreadsheet in calc, I get a message “Please wait for printer connection or cancel connection” I click cancel, and the document opens.

My wifi connected printer is turned off when not in use.

I cant find any hints on how to turn of this printer check using web search. Any help on disabling the message will be appreciated.


Version: (X86_64) / LibreOffice Community
Build ID: 36ccfdc35048b057fd9854c757a8b67ec53977b6
CPU threads: 8; OS: Windows 10.0 Build 22621; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL threaded

Try this, click Tools > Options > Load/Save > General and untick the box Load printer settings with the document.

If that doesn’t change the situation you could set a virtual printer such as Microsoft Print to PDf as the default printer. Being a printer located in the operating system it won’t need to wake up.

1 Like

Thanks for your suggestions.

  1. Unselecting " *Load printer settings with the document" made no difference. I restarted Office before testing. I will try this again while restarting my computer.
  2. My computer is set to “let Windows manage the default printer”, so I don’t have an option to set default printer. I need to think about how changing this would work with other programs on my computer. The “cure” might be worse than the “problem”.

Thanks again, I will experiment with default printer settings.


If the problem is the default printer selected by OS (heh, it is funny then how well Windows “manages” the default printer :slight_smile:), then you could try the opposite: select the Load printer settings with the document option, and then, in each document you work with, use FilePrinter Settings to choose a default printer that doesn’t hang :slight_smile: (don’t forget to save the document after that, so that the printer choice is in the document).


Hi, I’m having the exact same issue. ‘Load printer settings with the document’ on/off doesn’t make a difference.

It seems like ‘File → Printer settings’ doesn’t let you choose ‘no printer’, which is the case for me in the 99.9% of a time that I don’t have a printer connected. I just get a warning that no default printer is found when I try that; there’s no way to select e.g. Microsoft Print to PDF.

I’m on (X86_64), build 56f7684011345957bbf33a7ee678afaf4d2ba333, Windows 11.

I think I’ve determined the exact scope of the problem (at least on my machine), which I’m hoping could help with troubleshooting.

  1. This problem (an error message screen with just a ‘cancel’ option) occurs whenever I opened any saved document in Calc, but not when I just open Calc to a new document. The problem doesn’t occur for e.g. opening saved documents in Writer.

  2. This problem also occurs when I create fresh Calc documents, save them, and open them.

  3. If I turn off the Windows setting “Let Windows manage my default printer” and instead set an electronic option like ‘Print to PDF’ as the default printer, then previous saved documents still have the issue, but newly saved documents no longer have the issue. But if I then change the global Windows settings back to my actual default printer, those newly saved documents then start having the issue! This may indicate document settings are not correctly storing default printer information. Checking or unchecking “Load printer settings with the document” doesn’t have any impact on this behaviour.

  4. If I open documents with my normal printer connected, then the problem doesn’t happen, indicating that Calc really does care whether I’m ‘ready to print’ (even though I never print Calc documents).

  5. When I connect my printer it becomes possible to access File->Printer settings in Calc, but the changes I make there (like setting the printer to an electronic option like ‘Print to PDF’) don’t seem to stick after I close and reopen: Calc starts expecting to register my physical printer again, at least when the Windows settings say my physical printer is my default printer.

  6. Although technically keeping ‘Print to PDF’ as the default printer as a global Windows setting would prevent the error for new documents (not existing ones), the ‘fix’ is worse than the issue, as I’d need to manually reselect my printer every time I went to print.

  7. This problem only recently started happening. I don’t think it was coincident with a LibreOffice update, but it was after a Windows update. It’s also possible that I turned my printer on and off while I had Calc open, or opened and closed Calc while my printer was on, for the first time. I don’t think I’ve ever tried to print from Calc.

Summary: LibreOffice Calc has decided that whatever I have set to be my default printer must be available when I open the program and therefore throws up an error screen because I don’t keep my printer on. The rest of the LibreOffice suite doesn’t do this.

Do you only change settings before save? Then maybe your document is not changed.
I remember when preparing some templates to store settings for sorting I needed to do a minor change somewhere before hitting Save so my new settings were stored. (It was even possible to Undo the change and Save - the icon showed there eas a change registered.

@Wanderer these settings should likely be per-profile, not per-file.

Thank you for your detailed reply. I am still having the same issue, and I agree that it was triggered by a windows update, not a LibreOffice update.

This led me to an interesting discovery. You’re right, I made some document changes before and after changing File → Printer settings, then saved, and that does indeed make the setting ‘stick’. Unfortunately, this doesn’t resolve the problem. When I open a document in Calc I still have to click through the error message, and then I can go to File → Printer settings and see the printer is set to ‘Microsoft Print to PDF’ and the printer status is ‘Ready’.

It certainly appears that instead of checking whether the default printer set in Calc’s options is available, upon opening Calc is checking whether the operating system’s default printer is available, and throwing an error if it’s not.

(I also checked that ‘Load printer settings with the document’ makes no difference to this.)

I’ve been fighting the same thing this morning, except in Impress, not Calc. But after I click through the printer connection message, then all of my text is crammed together, with all the lines crammed together on top of each other at the top of the screen.

Turns out my problem is that the Liberation Sans font (which I’ve used for almost everything Libre…) has disappeared from my presentation computer after a recent update. If I change my font in my presentations from Liberation Sans to Arial, it gets over its little fit and works.