Printer Forms selection shows all form sizes in metric

How do I get the PRINT forms selection menu to list the forms and their sizes in Inches. e.g. when I look for Letter it shows “Letter 216mm x 279mm”. I’d like it to say “Letter 8.5” x 11""

My default measurement is set to Inches, not metric.

Is there another setting elsewhere for this?

Have a look at Tools > Options > LibreOfficeWriter > General --> Settings.

Then search “US Letter”.

With me:

Version: (x64) / LibreOffice Community
Build ID: d1d0ea68f081ee2800a922cac8f79445e4603348
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Sorry, as I said in my note, I have already chosen measurement units as Inches.

And how do you search for “US Letter” - I see no search ability in this dialog.

Change your Locale setting to one that uses inches; i.e., English (USA).

Tested with LibreOffice on Windows 6.3.


That worked, thanks. So LO believes by default that Canada is fully metric. Nice if it were true, but we’re still a mixed bag like the US.

1 Like