Printing multiple pages per sheet is SEVERELY limited. Why the change?

I often create 5.5"x8.5" portrait docs for work which I print 2pages/sheet on Letter sized paper. Have done this easily for years usingLibreoffice and Openoffice before that. Latest versions have made this very difficult by apparently forcing the page size to match the document size. So in this case, whatever I do, the program insists that I’m printing to A5 paper and will not allow me to change that to match the paper I’m actually using. The ‘print multiple’ shrinks the output to fit on the half sheet (A5) instead of the Letter sized sheet I’m actually using. Even trying to print as brochure doesn’t seem to work–it still shrinks the pages to fit on A5 paper. I can accept that it might choose A5 as a default, but why not ALLOW the user to change that to match the paper he’s actually using like I could in earlier versions? For that matter, why not give me the flexibility to choose how I want the pages to land on the paper whatever page and sheet and locale settings are selected? Obviously I can use columns or text frames on letter sized pages and number the pages and edit the headers/footer manually, that will work, but it may just be easier to revert to an earlier version of LibreOffice or OpenOffice that didn’t mess with the page size settings at all.

In which version does it work for you?

It worked in LibreOffice_4.1.1.2_Win_x86 but not in LibreOffice_4.1.2_Win_x86 . Using Windows 7 (no iWindows for me :). Before, I could change the page size in the printer properties and that would change the page size in LO. And of course in the REALLY old versions (<3 or so) I just input the page size in the LO dialog and it did it’s best to print a page that size regardless of printer settings or locale. More prone to user error, but MUCH more flexible, IMHO.

Hi @kszzm,

What you’re describing sounds like a regression in LibreOffice. If a feature you used to use isn’t there any longer, hopefully it’s something we can bring back. Please file a bug, provide us with accurate reproduction steps, and we’ll investigate.


Okay, I will try to clarify, simplify and illustrate and submit all as a bug. Thanks for your response.

Go to the properties of the printer and select the paper size you are actually using. Then coming back to the printing dialog go to the dialog page “Page layout” and make your settings.

That should work, but there seems to be a bug in the current version (4.1.3 and 4.2alpha for me), see last comments in and and and perhaps additional issues.

Thanks for the response. This is exactly what I have been doing up to the latest upgrade. It worked in LibreOffice_4.1.1.2_Win_x86 but does not in LibreOffice_4.1.2_Win_x86 .

** Read through these links - they seem to describe the issue very well, and it is serious enough that I have had to revert to an earlier version or another program for my work. The links are to - has the bug been submitted to Libreoffice?

I see that the issue has not been closed here, nor on the links for the bug, so here is an update for LibreOffice 5.0.

Version: (Arch Linux)
App: Impress (behaviour looks ok on Writer)


  1. Printing 2 pages per sheet doesn’t work. To replicate issue: Create new presentation with 2 pages → Print → Select 2 pages per sheet. The two landscape pages are side by side, not top to bottom. For Writer 2 pages per sheet will be correctly previewed (2 pages side by side if the doc is in portrait).

  2. If pages are set to say, A4, when printing the paper size will still be letter. This cannot be changed. FYI, Writer does not show this issue - the page size on the preview window changes correctly.

Having a slide set that cannot be printed correctly is a major issue. Hopefully it will be at least looked into. For now the workaround is to print to PDF, then use a PDF viewer that can print 2 pages per sheet, but it’s a very clunky workaround.