Printing problem on Mac Monterey

Since upgrading to Max OS Monterey and LibreOffice to print output is blank. This affects both Writer and Calc. In Writer the printer starts up, behaves as though it is printing but no ink is put on the paper. Pages are completely blank. In Calc the preview screen is blank.

Has anyone else expereienced this? Can anyone suggest a fix?

Printing to PDF also fails, but exporting to PDF works.

Using LibreOffice 7.3.0. Last night I updated to MacOS Monterey 12.2.1 (from the previous Monterey). Today I’m seeing:

LibreOffice frequently crashes.

But more important, as Jimb2 reports, it only prints blank pages. This is new.

But disabling Skia fixed it. Very strange. Where might submit a bug report? I’m sure this will impact a bunch of people.

Update: Never mind, I see that there’s already a bug report.

Thanks to all, disabling Skia and restarting LibreOffice has fixed it.

Bug tdf#146842

You may be able to disable Skia in LibreOffice > Preferences > LibreOffice > View and under Graphics Output untick Use Skia for all rendering and OK out

Thanks EarnestAI that fixed it.