Problem copying between spreadsheets

Running LibreOffice 4.3.2 on Windows 7 Professional 64 bit. Core i7, 8GB RAM, 672 SSD.

Here is the scenario. My first spreadsheet contains 9 sheets. My second spreadsheet is new (blank). I need to consolidate the 9 worksheets from the first spreadsheet to one sheet on the second spreadsheet. I highlight the area I need on the first sheet on spreadsheet #1. I copy the area then paste it to the sheet on spreadsheet #2. Success!

Now I go to the second sheet in spreadsheet #1, highlight the area and copy it. I go to a blank cell in spreadsheet #2 and paste. It seems that the clipboard retains the contents from the first copy operation, because that is what is pasted. All other attempts to copy from spreadsheet #1 to a blank area on spreadsheet #2 have the same result - the first copy operation is the one that is pasted.

However if I limit my copy/paste operations to the same spreadsheet (copying from every sheet onto a blank worksheet all within spreadsheet #1), then all the copy/paste operations work as expected.

What is going on?



I made a test in LibO on an XP machine and do not observe the problems you report.

May I ask you to verify again the copy&paste procedure - especially if you really copied the content of the 2nd and 3rd… spreadsheet. Should you again observe the same behavior, please file a bug report here:

edit after comment

@Jon1 - your question was deleted by mistake; you didn’t make anything wrong. The person who deleted it unintentionally did efforts to get it undeleted.

I made a test in the portable version LibO 4.3.2. Coping and pasting between spreadsheets is working fine. Thus I would now see if a reset of the user profile solves the problem. If not please file a bug report.

Reset of user profile:

Yes, I can verify that the copy/paste procedure was performed correctly and as described. Within the spreadsheet, copy/paste works correctly. Copying to another spreadsheet does not. There are no copy/paste issues with any other program. No clipboard extenders. However, AFTER experiencing the problem, I tried an extender and got the same results as reported.

By the way, my post was deleted. Did I do something in violation of forum rules?


Thank you for your help. Before I tried resetting my settings, I rebooted. As stupid as this sounds, it worked. I can now copy/paste correctly between spreadsheets.

Thanks again.


Glad you found the solution.