Problem Created by Microsoft W10 Update KB5013942

Yesterday, May 12, W10 installed a “Cumulative Update” (KB5013942). Today, while attempting to use the LO Writer Search and Replace function for a spacing/formatting mark the Search and Replace function reported after the task that the task had been completed, but none of the replacements had been made.

I then tried the same search and replace operation on several different documents, all with the same results. This had never ever happened previously. Previously, the search and replace function for a spacing/formatting mark had always worked, without fail.

The only change that had been made was the installation of Microsoft W10 Cumulative Update KB5013942. I uninstalled the update. Thereafter, the LO Writer search and replace function for a spacing/formatting mark worked properly. Has anyone noticed any other LO problems with this particular W10 update?

Can anyone explain why there might be an LO Writer search and replace problem with this particular Windows update? I will be posting about this problem on a Microsoft community site. If I see anything that is possibly interesting to the LO community, I will post it as an update to this question.

What, specifically, I was trying to do was to replace multiple spacing marks (… or … or … - not periods, but spacing marks) with single spacing marks.

I’m using LO (x64) and Windows 10 Pro 21H2

Please upload a shortened and anonymized document, in which the problem is present, here.
And post your search command possibly as a screenshot.
Thank you.

Find and Replace works fine for me.

I tend to restart again a few minutes after the Update restart these days as Windows is often a bit flaky with only the one restart after big updates

Version: (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 8; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: threaded

After the most recent Win update on my PC LibreOffice didn’t start at all.
A quick run of the LibO installer with ‘Repair’ option remedied.
(I’m tired of all the problems caused by MS. Therefore the resort to the hammer.)

(I’m tired of all the problems caused by MS. Therefore the resort to the hammer.)

First of all, I am not the defender of any operating system here.

I have two laptops on Win11 with the above update and no problems with LibreOffice.
Can it possibly be due to the user regarding settings in Windows?

I would have gladly switched to Linux. But when I see the problems here on the list on this topic, no thanks. Linux Mint, Linux this and Linux that. Install packages? Well, who likes it.

I never had a problem with Windows (toi, toi, toi).

Actually I don’t think the observations on search/replace are really connected to the update, but this is difficult to check with current data.

We had this year a lot of skia-problems and the printer-issues caused by MS itself. Also using certificates in windows with LibreOffice seems to have fundamental problems for some users

A lot of linux-trouble results from people who have not installed their LO. So where should they know of maintainers wich leave out java and how to approach this via apt/rpm etc. Libre is just the office they found on their computer. Also they are often not aware they selected a desktop, wich can cause their own part of problems.