Problem installing LibreOffice_4.0.3_Win_x86.msi on Windows 8

I’m sure its just my ignorance but I cant install LibreOffice_4.0.3_Win_x86.msi on my Windows 8 system.
I downloaded the file from the Libre Office website along with the help file but when i double click the LibreOffice_4.0.3_Win_x86.msi file ‘Free Zip Opener’ opens but seems to do nothing to the file. I used another zip opener and extracted the file to a new folder but cant find any install .exe files or other files that want to install the software. I deleted everything and started again but still cant get it to open.
I am totally lost these days with most things concerned with the ‘magic box’ and so appreciate that I am probably doing something totally daft - I was under the impression that clicking the .msi file would start the install sequence.

OP: @woody

I had the same problem with the Free Zip opener, but I found out how to install msi files manually.

Keyboard: win + r
and then just type in like bellow:

msiexec /i -path-/-msi file-

Example: msiexec /i C:\Users\user\Downloads\LibreOffice_4.1.3_Win_x86.msi

I had the same problem and solved it. It looks like the .msi extension has been hijacked by the “Free Zip Opener” in the Windows Registry Key “HKEY_CLASSES_ROOT.msi”. The default should be “Msi.Package”. There was an “oldValue” that I could copy, which was kind of rudely polite. After I made the change I double-clicked an .msi file and I got a pop-up that a new program can use this file type and was given the choice of “Free Zip Opener” or “Windows Installer”.

Please read all of the blah blah blah about using regedit and backing up the Windows Registry before trying to fix this. I repeatedly commit heresy by updating the registry and I never take a backup.

I don’t always test my code, but when I do, it’s in production.

I think your impression is right, try with right click selecting run as administrator.

Maybe the compressor program have the option to select what files have associated, if msi extension is there, try disabling it.

Thanks for the quick response.
I tried right clicking but ‘Run as Administrator’ is not an option.
I also tried changing which program opens the file via ‘Open with’ and changed it to msiexec.exe but get the message ’ This App cant run on your PC '.
Does this mean that ‘LibreOffice_4.0.3_Win_x86.msi’ wont run on my windows8 system or ‘msiexec.exe’

Please what is the all name of the file and the size?.

Hi, the file file name is: LibreOffice_4.0.3_Win_x86.msi and it is 187,340kb. Since posting I have had similar problems trying to install another .msi file and so am assuming that there is an issue with installing .msi files on my system. I think there is a problem with windows installer msiexec.exe but getting very confused.!

Maybe your computer was infected by some virus which change msi file extension association, so it does not run. Msi should not lead to free zip opener…

You can try with
All you need to do is do download file, extract it and try to run Writer, Calc or Impress… no installation is need in this case.

Hi Ljijan, thnaks for that - I’m trying it now. I have discovered that there is a problem on my system running (or is it installing?) .msi files. I downloaded a non microsoft installer which unpackaged most of LibreOffice, however it does not appear in the metro screen and I have to open from a folder. Does anyone know how I replace the .msi installer on windows 8?

LibreOffice portable downloaded and works fine. Thankyou.

maybe the easiest solution is to uninstall free zip opener.

I am searching for a long time the easiest way to uninstall my zip file for my windows this will help me in this more, I also have a Kindle device which has software issue and which I get resolve by Kindle Customer Service that support me like you do in my problem.