Problem opening documents containing Hebrew words in the path

I have KDE neon with Hebrew system language.
I cannot open documents that contains Hebrew words in it.
The problem is only on applications of LibreOffice.

In the document itself it is possible to work in Hebrew.
The problem is only in the open file menu, and opening a file from the file explorer or the console.

Have you set the Default Language for Documents to support COMPLEX TEXT LAYOUT? On my Linux/mint this is shown in TOOLS > OPTIONS > LANGUAGE SETTINGS > LANGUAGES > HEBREW.

That did not fix the problem. (I opened an English - named file and thought this is OK).

I don’t have Hebrew in the pull down menu.

I assume that you are using a full LibO file .odt not .doc or .docx. And you have a font that contains Hebrew characters such as David Libre? I am sorry, not being and expert in Hebrew רשתװױײצצ תװלמננ