Problem pasting formulae

I know my way around spreadsheets pretty well, but for some reason, pasting is not working as it should.

  1. I put ‘1’ into cell A1
  2. A2 = ‘A1+1’. ‘2’ shows up. All fine and good.
  3. I copy cell A2 into A3.
  4. In A3, instead of ‘A2+1’, I just get the value ‘2’. No formula.

This is on Win7-64, with latest version of LibreOffice, I’ve looked for some preference, but have found nothing.

I also had this problem recently with OpenOffice 3.3, which had worked fine for at least four years. Something happened in the last month or so to throw off the default pasting functionality. I am not doing ‘Paste Special…’

Thank you, and greeting from Vienna!


In much cases this help, try resetting the user profile:

HAH! That did the trick. Everything is now ducky, and I am one happy camper. Muchas gracias!

ToolsCell ContentsAutoCalculate
When this option is checked, contents of cells will be automatically calculated.

To update all cells, including those that changed during the time AutoCalculate was disabled, press F9 or click on ToolsCell ContentsRecalculate.

Hmm, thanks for the response, but that doesn’t do the trick. I’m thinking maybe the problem is rather with copying a cell, than with the pasting. It’s like when I select and copy cell A2, it’s only copying the text in the cell (2), but not the underlying formula (=A1+1). But for years, it had always copied the formulas (and all formatting too! – i’ve lost that also). e.g., in this simple example, I could copy that one cell, and paste to a whole column range, getting a sequence of consecutive integers. I don’t know what happened…

If you suspect problem occurs during copying, see if you have some clipboard manager installed. Maybe it is interfering, so check if turning it off brings back normal copy-paste behavior.

Tools/Cell Content/Auto recalculate needs to be set from what I can see.

Ah, shame - I had exactly your problem and the Cell content switch worked for me, but I’ve not tested whether it overcomes the issue of pasting to a column or row range on my set-up. I’ll give it a try dreckly. arob

Oops - wasn’t looking a thread posting dates. I guess this issue is history. Regrets if you have e-mail notification set up.