Problem saving changes to a file

Recently upgraded to Linux Mint 21.3, but this doesn’t appear to be a problem with upgrade from Mint 20.3. When working on a presentation in Impress, I routinely save changes as I work. However recently I’ve discovered that my changes are not being saved! Rather my file reverts back to a previous version and does not save the current version? The changes appear to be saved but if I quit Impress and reload the document it reverts to a previously saved version? Never had this problem in several years of using Impress with Mint.

Please name:
Which version of LibreOffice are you using?
In which file format do you save?
Where are you saving to?

Libreoffice Community
Saving presentations in odp
Saving to /Home directory on internal computer SSD
Hope this helps

So far I haven’t found a solution. I had uninstalled the version of Libreoffice installed with the upgrade to Mint 21.3, and re-installed but no improvement noted. What I’ve discovered in the last 2 days is that not all files are effected by whatever the problem is. It appears only a couple of my presentations cannot be saved with the changes made to them. But it becomes highly problematic if you have to be constantly checking to see if changes made to documents are in fact saved when you think you’ve saved them!

Please test in safe mode, Menu/Help/Restart in Safe Mode

you should upgrade to 7.6.

Tried using safe mode. Makes no difference.

The version I’m using ( is the current version in the official repository for Mint 21.3. As a matter of policy I try not to install third party software or stray off the reservation with updates other those from the official repositories for both safety and security. However, since clearly something isn’t working right, I may give that a test to see what happens.

Im working on a different presentation for this weekend where this problem has cropped up again. Oddly, if the slide that won’t save properly is duplicated (select slide, right click and choose duplicate) and then this copy is edited, the change is successfully. It’s parent slide that is “frozen” in its previous state and can be edited but changes are not saved. Really strange.

After several failures to isolate the problem. I finally decided to take a risk, and do as fpy suggested. I uninstalled the “official” libreoffice version supplied by the software manager for Mint 21.3, and install an updated version from the download website. Used Mint 21.3 software manager for the uninstall. Rebooted. Then downloaded Libreoffice 7.5 as recommended at the website. The package downloaded was LibreOffice_7.5.9_Linux_x86-64_deb.tar.gz. The deb file was extracted and installed. So far so good. I rebooted and opened the draft presentation that had earlier failed to save properly, made several edits then saved the file, rebooted and reopened the saved file. Voila! This seems to have solved my problem. Still no clue as to why the older Libreoffice version fails to work properly with Mint 21.3.

the bug mentionned earlier (tdf#15316) is pretty explicit :wink: