Problem with Base connecting to existing Db after upgrade/reinstallation

Hi, I would be most grateful for any help.

My setup is
Windows 7 64 bit
Libre Office Version x64
JRE 1.8.0_161 located at c:\Program Files\java\jre1.8.0_161
The jre is visible at options\ advanced\java
I’m unable to connect to a database that previously worked. This was originally created as an access database and LO connected to it via 78database.odb. The database stopped working as it usually does when the there is an LO update warning. Previously I have upgraded by downloading the new version and installing. This time however I was unable to make it work.

So I tried uninstalling the new version and re-installing again. I also updated the version of Java I was using taking care that it was the 64bit version as was the new version of LO.

I tried creating a new instance of database to an existing database, selected access (the 2003 version) and browsed to the mdb file in its usual location on a network server. The dialogue filled in the database path but then tells me that it is not available.
Message is 'Connection to the database arbuthnot could not be established. The connection could not be created. May be the required data provider is not installed.

The system overall is also displaying instability. If you click on the .odb file (as before) the application opens but is none responsive. It will alternate between full screen and taskbar icon on approximately a 15 second cycle until eventually you get bored and close it down with task manager. On restart of any LO application it will insist on recovering the database and any other recently used applications. It then reopens them and the base window is again non responsive.

Thanks for any help.


Did you upgrade LO from 32 to 64 bit?

I certainly did. That looks very much like the answer. Thanks for your help.


You may want to see this bug report - No Access connection for 64 bit LO (Windows) .

You can probably still use LO 64-bit and connect to Access with a JDBC connector. See my answer in this post - mdb files not loading to base for further information.

Thanks very much for pointing this out. I think that in my case the most sensible answer is going to be to re work the database and get away from using the old .mdb file.

Once again, thanks for your help. Doug