Problem with bullets appearing as square glyphs when imported from word doc

I am using LibreOffice on a macbook pro running Mountain Lion. When I open a Word file (doc or docx) that has been sent to me, the default bullets appear as strange square symbols which come under the Symbol font [private use subsection]. I have tried using a font replacement table in the preferences - replacing the Symbol font with OpenSymbol - as this problem has been discussed under the OpenOffice forum. However this doesn’t solve it for me. If I change all the bullets to a simple dot then save as a doc or docx file, when I reopen it they are back as the square glyphs. Only if I save the tile as an .odt file do the changed bullets stay as dots.

I work with people usually using Word and want to be able to save my files as Word, work on them as word and share them being confident that odd formatting problems will not show up. How can I solve this? Any ideas out there?

I would like to add a picture of the odd bullets that I get, but karma level won’t allow me to upload one.

this is a bug that was created in 4.1…i have the same issue. i didn’t have it until i upgraded to 4.1.

the resolution for 4.0+ (which was to go into preferences and add a replacement table for symbol → opensymbol) doesn’t seem to work in 4.1.

edit: just downloaded 4.1.2, the problem seems to be fixed.

Thanks - the 4.1.2 version has solved the problem!

Version creates a DOC file that is considered corrupt by Microsoft Office Starter 2010. I have bullets in the document. If I agree to Starter’s offer to “trust” the corrupt file, the bullets appear as some unexpected Unicode characters.

Can you write step by step instructions how you produce the squares. I use LibreOffice 4.0.5 on Windows and can’t reproduce this problem. If you can reproduce the problem in step-by-step then I suggest to report a bug at bugtracker:

I perfectly well understand that you would like to get as much of the same appearance with MS-Word, I would like to have too. But time to time I just get some corrupted formatted text. The only 100% sure way to get the same result is to have exactly the same tools (this is not specific to LibreOffice). So all users should use MS-Word or LibreOffice Writer. One other option is to exchange documents in file format that is really a true standard like PDF format - if editing is not needed.

The steps to get the squares [I am not really producing them myself - the file was prepared by someone else] are simple: I receive a .doc file from someone by email, open it directly with LibreOffice from the Mail app and what should be simple bullets appear with the square glyphs. I will edit my original question to show what the strange bullets look like. I am not sure otherwise how to describe the problem - and haven’t used bugtracker before. I think the problem is specifically a mac one.

I realise also that to avoid mismatches between people sharing files is to use the same tools - and that using PDF files solves some of this. However I am not bothered about small formatting differences [like the number of pages, margins or so forth] - but this problem with the bullet style seems more fundamental to me and more of a glaring problem.

it’s a file format compatibility issue which i raised the issue some days ago too.
if u r able to open the doc in ms office, probably saving into ODT format before opening with LibreOffice might do the trick of not changing original bullet styles.

I can open the document in MS Office without any problem - but you cannot save to ODT format from MS Office. Anyway that would not solve the problem as I would prefer to do away with MS Office altogether.