Problem with changing document language

My default document language is Italian, but sometimes I work with English documents. I can change the document language with Tools/language, selecting " entire document". However, when I do this and then do a spell check, the entire document is highlighted. This is very annoying, and I can’t find any way to remove the highlighting without also undoing the spell check.

Using direct formatting to set the document language is always risky: it’s better to use styles. To change the language of the whole document, go to the style editor in the side bar, select the paragraph styles block, right click on the Predefined paragraph style and in the Font tab you’ll be able to set the language. Because most paragraph styles are based in Predefined, the new language setting will propagate to all the other styles.

By using styles you can even work with multilingual documents: just set as many paragraph styles as languages you need.

BTW, what do you mean by “the entire document is highlighted”? The text change background color? If you cannot solve the problem with this answer, please, edit your question to add more information and, if possible, a sample document showing the problem.