Problem with cyrillic letter "b" in Linux

I install Fedora 22 and update LibreOffice to version 5. When I opened old document or start new document and start to write in Cyrillic, all characters are fine except small letter “b”. It looks similar to Greek letter d (delta), no matter what font I am using.

I tried LibreOffice in OpenSuse 42.1 and situation is same.

The problem is the easiest to observed with Liberation Serif, but is evident with DejaVu Sans, Source Sans Pro…

Does somebody have similar problem?

Hi Giagor,

My config is Fedora 23 with LibreOffice 5.0.3. I opened a new document and typed CYRILLIC CAPITAL LETTER BE, CYRILLIC SMALL LETTER BE and GREEK SMALL LETTER DELTA both in Liberation Serif and DejaVu Sans and cannot reproduce the problem. See attached screen shot.

image description

Even at point size as low as 10 points, they look different, even if it becomes difficult to discriminate between the two. To make sure your fonts have not been corrupted in some way, have you tried to display the letter at 36 pt for example?

UPDATE after your answer

Your file displays the same as your snapshot in my LO. I had a look at the internal XML. Your text contains D0 91 and D0 B1 which are correct UTF-8 encodings for CYRILLIC CAPITAL/SMALL LETTER BE. I am not accustomed to reading LO XML but your text has style “P2” which is a symptom for manual format attributes. Style “P2” is based on paragraph style “Standard”, the only addition being language sr_RS (Serbian from Serbia).

I tried to clear manual formatting, but nothing changed.

I then switched the text language to English. Letters displayed with the expected shape. I tested other languages like French, Russian or Ukrainian. The glyphs kept their distinctive shapes. When I switched to Serbian (Latin/Cyrillic, any country), the small b displayed as a Greek delta.

I am not at all familiar with Cyrillic writing. Do you know of a typographic rule in Serbian which would use shape variant(s) for some glyphs such as the b?

If this is the case, this is the intended behaviour.

Have a look to menu item Format->AutoCorrection->Options. There are 2 tabs related to automatic transformations while you type. You may eventually disable this transformation from here.

I have not tested this possibly since I did not download the Serbian language pack.

Hi ajlittoz,

I tried with new document and problem disappear.

Only explanation is that problem is some incompatibility with LibreOffice documents created in LibreOffice 5 for Windows and LibreOffice 5 for Linux. I created another document in Windows,opened it in OpenSuse 42.1/LibreOffice 5 and problem persist.

Can you test attached document?

Letters B.odt

This is snapshot:

See my answer update above