Problem with Firebird in LibreOffice Base

Hello again and happy new - covid free - year !
I’ve read carefully your remarks. I’m a newcomer in LO. I had worked with MS Access before, almost 20 years and a little bit with Open Office. Now I must have a database and it’s like to start all over again. And I think that you can make the best start with the tutorial. Firstly, I installed LO version The only step I didn’t follow is that I choose embedded Firebird because I read that HSQLDB is out of date and it will be replaced in the future. I followed step by step (apart from the aforementioned choice) the ’Libre Office, Getting started guide, Chapter 8, Getting started with Base’, I created a new database (called Automobile), I followed Step 1: select fields (I used the CD collection sample table in the personal category and Employees in the business category), then Step 2: Set field types and formats, then Step 3: Set primary key and when I followed Step 4: Create table (page 11) and clicked Finish there was the following ERROR displayed:

firebird_sdbc error: *Dynamic SQL Error *SQL error code = -104 *Name longer than database column size caused by ‘isc_dsql_prepare’

I thing that I gave all the details of the procedure. This is the point where I need some help.

Please don’t use all uppercase in your title - this is considered yelling.


Cannot duplicate on Ubuntu 20.04 with LO v7.0.3.1

Please provide more information - OS used; specific LO version; Exactly what you are doing including names and field types/sizes used. Can’t refer to anything unless the problem is identified. My best guess is you may be using a an older LO version than I tested with.

Thank you very much. I’ll try with the older LO version and I’ll give details as soon as I have time. Thank you very much again !


I believe you do not understand. My newer version will not allow names longer than 30 characters. I believe you are using an older version than I am and that is how you are getting an error. But I can’t say for certain. This is why I asked for the information in the above comment. Please provide that information. You using an older version will almost certainly not be of any help. You will most likely get the same errors.


Just an educated guess. Try creating the table where the table and field names are less than 30 characters.

Dear @Ratslinger,

Sorry for cutting in,

I can create filed name with 31 characters.

"Address07IndustrialEstateEnglis" VARCHAR(50),

Will there be any problem in the future ?

Fedora 33 Workstation + LibreOffice 7.0.4/Base:Embedded Firebird


31 seems to be current limit.


Still cannot reproduce your error based upon your latest information. Can generate a different error if large field sizes are used.

Do need this information previously asked for:

...including names and field types/sizes used. 

This is field and table names and field types and sizes.

Just finished following all the steps as in the documentation (but used Firebird embedded database as in question) and had no problems. Used default table name and all settings as noted.


Can only guess there is something different with your creation than the document or my entry. Problem is that it cannot be seen as to what you have.

I see. Thanks !

It still doesn’t work


Here is a copy of the Base file I created from the instructions - Automobile.odb

If I didn’t find the solution I’ll probably try openoffice again

I tried it again twice. I don’t know if the problem is the Greek language but I don’t think so. There must be something else.

I tried to create a differnet small database with four arbitrary fields and it worked. This is weird !!

Well it seems that the language is the problem. I changed the field names from Greek to English and guess what ? It WORKED !!!

After a lot of attemts both with wizard and in design mode, I realized that that Greek language of field names is a problem when I tried to reproduce the tutorial. When I typed the same names in English language there wasn’t any problem. I dont’t know what will happen when I will add data in Greek language. When I’ll reach that stage, I’ll see.
But typing field names in Greek (in the tutorial) causes a problem. So, the answer is to type field names in English (I don’t know about other languages and I don’t know why there’s a problem with Greek language).
Also, I don’t know what will happen if i try to create a new database with the field names in Greek. When I’ll have free time I’ll check it out.