Problem with locale setting (does not stick) Peru

I tried to switch from OpenOffice Portable to LibreOffice Portable since its release.
Since the default Decimal separator for Peru is wrong (the right one is the dot not comma), I try use the following language settings :

User interface : Spanish (Spain)

Locale setting : Spanish (Ecuador)

Decimal separator key : Same as locale setting

Default currency : PEN S/ Spanish Peru

These settings stick only if I start LibO as administrator every time. If I change the settings without starting LibO (and restarting it also) as administrator, the User interface will stay at English (USA).
I would like to be able not to start LibO as administrator every time and have the language settings stick.
Thank you very much for your help.


The locale not being persistent must be some quirk with the portable version, maybe it depends on what user actually mounted the USB device, for example a user may not have write access to the device if it was mounted as a different user.

However, thanks for the hint about the wrong separators in the es-PE locale, this will be fixed in one of the next releases. See

fdo#61449 · Status RESOLVED FIXED · LibreOffice 4.1.0 / 4.0.3.