Problem with mysql jdbc thai language in 4.1 version

I did successful connecting mysql from LibreOffice 3.6 (using Base) via jdbc.
But for 4.1 version, the problem arises.
The “Sa-ra” (Thai word for upper and lower character) are all gone.
Is this a bug?

Would you explain in more detail where the “Sa-ra” (upper and lower character) control is meant to appear - i.e. is it a menu, which window is it in, etc?

First of all, thank you for your comment.

I tried to attach pictures to let you see the problem, because it is hard to explain (for me, at least). But my karma is not enough, I can not attach the pictures.

But let me answer about some of your questions.

The problem arises when I open the table in Base. The data in the table shown in Base version 3.x is correct. But for the 4.x, all the letter that is a upper or lower of the normal line disappeared.

For example, Thai word ก๋า. As you can see, there is the + sign above the “ก”. That kind of character is called “wan-na-yuk” (some of them called “sa-ra”) in Thai. And instead of showing “ก๋า”, the version 4.x shownn “กา” only.

Hope this would make it clearer. Thanks!

More information, openoffice 4 does not have this problem.

I suggest to report a bug to bug tracker: and write details of your findings - that it worked fine on 3.6 and it also worked fine openoffice 4. In title of bug add [REGRESSION] at the beginning of bug’s title text.

Maybe if you have time and will also try installing LibreOffice 4.0.6 and find out if this is working fine in 4.0.6: Index of /libreoffice/old/ The more tests you do and the more info you provide the easier developers will find out in which version regression appeared.

I have found the solution.

I need to change the display font in table(or query) that is appropriate for Thai language.

Thanks everyone.