Problem with numeral digits and some Hebrew fonts

The following problem started a few days ago. Possibly after upgrading LO. I had not seen it before. It also partially affect existing documents.

Version I am seeing it with: (X86_64) / LibreOffice Community
Build ID: 420(Build:2)
CPU threads: 2; OS: Linux 6.9; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

It seems to happen only with some fonts.
It could be the simplest way to reproduce in Writer is:

  1. File → New → text document. It is probably important that I have Tools → Options… → A tick at Complex Text Layout. I possibly have other RTL related settings which I forgot at this time.
  2. Key in some digit. As if you want the 1st character in the 1st line be a digit.
  3. Depending on the font, the digit will appear, or not appear, on the screen. If it did appeared on the screen,
    3.1 From the fonts selection box at the top of the window, the box under the menu, select Noto Sans Hebrew. And key in the same digit again. This time the digit does not appear. Instead, the effect is as if you have pressed the tab key, and some white space characters ( ) are inserted in the document.

Does any one else seeing this, or something similar?

Issue disappeared. I do not know how. Possibly some package update solved it. I would have deleted this tread if I knew how to do that.
As an aside, numerl in the title is a typo of numeral.