Problem with Window Plotting

Current stable Mac version of LO. Writer.
Started having a persistent problem with some or all of the text, along with the “paper” background, disappearing from the screen. Clicking in the header area brings everything back. As does anything else that makes the LO window re-plot - such as opening and closing a browser window on top of the missing text. Rolling the cursor into the top line of text allows me to edit it, but rolling any farther down beyond the text causes another page disappearance. The window data disappears again, often leaving nothing but the header area and the left margin area. I tried re-installing the app, but the problem remains.

I have screen shots.

File “NewFoo 0” has one very brief line of text.

File “NewFoo 2” Simply rolling the mouse vertically down past that line of text makes the text disappear. As does rolling onto the page from any other direction. What’s left of the page varies sometimes, but it has lost much of the background that forms the virtual page. If I click in the header area of the page, everything returns to “normal”.

NewFoo 0.tiff

NewFoo 20.tiff

Formatting edited by ajlittoz on 2020-08-26 to enable screenshot links

If set, try to disable OpenGL in LibreOffice -> Preferences -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use OpenGL for all rendering and check whether that fixes your problem

btw: To upload an image **[edit](** your question and use the paper clip symbol, which appears in the middle of the toolbar (see screenshot):

image description,

Thanks for your reply. I’ve now tried it both with and without OpenGL Their seems to be no difference. it was unchecked to start with. Screen shots now added. I had to change screen resolution to tell that is a paper clip.

You may need to restart the software before a change of graphics library is effective. Whether you did that is unclear, so just in case:

On MacOS, closing the window does not quit the application.

After changing setting for use OpenGL, press Cmd+Q or find Quit in the application menu.

When no LibreOffice app icon is marked in the dock (underline or dot below, or some background coloration, depending on MacOS version and “skinning”), a graphics library change should take effect next time you start LibreOffice.

Thanks again for your reply. As it happens, when a change of the OpenGL attribute is made, the Preferences machinery prompted me for a restart. I took the bait. Then went back to make sure it actually changed. It appears that all happened as it should. Unfortunately, didn’t help.

@anon73440385: attaching a screenshot or other graphics is done with the “slide” tools (for “supported” formats, otherwise the “paperclip” is indeed the fallback tool). Here, it looks like .tiff is not recognised as an in-line graphics format.

@ajlittoz - of course you are right and my mind has been somewhere else in this universe…

Do I take this response to mean .tiff is not an accepted format at all? Or only when using the paper-clip tool?

It’s a sad situation that it’s not an accepted format, since it is widely used for screen captures in the Mac world. On the other hand, If I had known, I have apps that can convert .tiff to other formats.

What are the “slide” tools? Where do I find them?

.tiff is accepted as an attached file (you did it with the paperclip tool), but I discovered through your question that it is not accepted as an inline illustration (.jpeg and .png are and probably a few others).

The “slide” tool is immediately to the left of the paperclip (see screenshot above).

This kind of erratic behavior tends to happen when there is an update to graphics drivers/modules on your system, and usually more pronounced with third party applications (LibreO, Microsoft, Adobe, Mozilla) than when using Apple software.

Check whether you have updates pending, or awaiting a reboot.

OOKLA Speed Test was the only pending update. Updating it didn’t help. Thanks for the tip!

For the records:

see answer in question

Hint: Reset user profile using the following procedure:

  • Start LibreOffice
  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Select option Reset to factory settings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

This problem was caused by corruption in the User Profile. Once I knew that, I replaced the User Profile by removing it from the folder ~ > Library > Application Support. The LibreO app automagically provided a new, unblemished User Profile folder on the next launch. Problems gone.

The procedure in my answer is exactly this.