Problems setting up a connection to a MySQL Database

I am trying to get MySQL and LibreOffice Base working on a stand alone PC.

I have tried ODBC (errors installing MySQL ODBC so gave up), JDBC and connect directly both give “Communications Link Failure”.

I can connect via MySQL Workbench and create and modify tables etc. So I believe MySQL is up and working.

Are there any log files which would shed more light on what is causing the error?


Basically, for one reason or another, your network connection attempts to the db server are either timing out (this can happen when using a remote, internet based host) or else firewalls are blocking the traffic or something else is hogging the bandwidth.


Hi Alex,

I have partly solved the problem. What the unhelpful error message really meant was “Invalid Hostname”. Once I corrected this I have been able to create tables etc in LibreOffice base which do appear in the MySQL database. So far so good.

What does not work is actually getting any real data into the system. When I try drag and drop from either another base window or from a calc spreadsheet all I get is “CREATE command denied to user xxxx@localhost for table x”. Yet I am able to create tables willy nilly from within base OK.

Is this a bug or a limitation?

I would check out the user’s rights on the mysql server first. If those are all OK, then it might be a bug.
My thinking, which could be completely wrong, of course, is that you require absolute GRANT privileges on the server for the user connecting to MySQL via LO in order to be able to copy/drag/drop from another source. Like I said, I could be wrong, and it could be a bug with the windows version.

Yes I made sure in the first place that the user had all rights including GRANT.

Problem solved. The schema prefix was missing.