Quotation mark and Apostrophe

To get the above characters to appear on the page I am typing, I have to press the space bar. This has been going on for some period so I need the answer how to rectify this anomaly I am using Libre Office (Additional info as requested:I am using Win 10 Pro 64 bit OS and my language on my system is English (United States) International)

This kind of behaviour occurs with “dead keys” (usually diacritical marks like accents). This is handled by the keyboard in the OS (which you did not name). You may have inadvertently changed the keyboard language.

Provide further information by editing your question (and clearly identify the edit). Answers are reserved for solutions; they are not a thread: you are limited to a single answer.

So this is a question “How do I use features of my OS?”

The answer might be in the OS documentation - like this (I assume that that documentation is also true for Win10).

Personally my opinion is that en-US-Intl keyboard layout is harmful, because it prevents detecting current text language from your input language and keyboard layout. LibreOffice can do that if you use, say, de-DE input for German text; ru-RU for Russian text; en-US for US-English text, and so on. But having en-US-Intl keyboard layout, you use it for any Latin-based script like French, Czech, Finnish, etc - and LO cannot help you setting proper text properties automatically.

en-US-Intl keyboard layout is harmful,

Why, you can simply set is as the layout for any language. Thus, it is very useful (especially in Linux where it lets you type virtually any Latin-based character, while the Microsoft version just sucks offering only Western European ones [by the way, you can’t use it for Czech for missing the very Czech letter ů]). Just it is not for idiots.

possibly - I agree I can just be unfamiliar with it. Unfortunately, on Linux, it seems to be no way for LibreOffice to take advantage of the input language - or I may be misled again (I’m using Windows mostly, so my understanding of tdf#108151 might be wrong).

I can’t confirm the mentioned bug now. In my case (openSUSE Leap 15.1/KDE) LibreOffice of the 6.x branch seems to correctly accept my input languages. I had such an issue very long ago in OOo, but it was the same for Windows (then XP) as well.

Does the problem persist when you change to a different font? I recall that some fonts (can’t remember which) do not display some punctuation marks very well (cramped or too small). Which font have you been using?