Read Only doc issues

A document that I have been working in for months now decided to cause problems today. It will only open in read only mode. I tried saving as a new name, and that one would only open in read only mode. I tired copy-pasting the text into a new document, and that one would only open in read only mode. I tried copy-pasting the text into notepad to clear any formatting and then into a new document, but the formatting windows became … messed up. Font and size were blank and would not change, I could not click on rulers, and when I opened the paragraph formatting window, everything was blank instead of showing default settings. These settings work fine in other documents

I WAS finally able to open the doc in MSWord and save as a new editable document, but now the original documents will not allow me to delete them. When I try to, it says that the documents are owned by an unknown user or that they are still open in MS Word (before I ever attempted to open them in MS Word). Note: I never use MS Word, I prefer Libre. Restarting my PC does not help.

Another note: other documents open fine, it seems, so far.

My first step when this happened was to try changing all the permissions to myself as admin, and full access for all users, but that did not fix anything.

Any ideas as to what is going on?

Edit: The doc that I was able to edit is now locked as well…

I will leave the question there for others having this issue.

I figured out what was going on.

I have the preview pane open in Windows 10. This opens MS Word under an svchost, so when Libre attempts to open the file, it is locked because MS Word has it open. If I force closed MS Word under the svchost, the file opened just fine.

Lesson of the day: don’t use Windows 10 preview pane.

Good answer. Please mark it as correct by clicking :heavy_check_mark:.