Recover .ods files


I deleted by accident a very important .ods file. I used the foremost recovery program and I was able to trace the document. The problem is that the document is not recovered as an .ods file but as a set of xml files (content.xml, meta.xml, mimetype, settings.xml, styles.xml).

What I would like to know if there is a way to import the original document from these xml files? I tried to open the content.xml doc in LibreOffice and it crashes. Also tried with MS Office Excel and although it openned, the information is unformatted and dispersed along the spreadsheet making it almost impossible to recover the data.


Have you checked to see if you have a version available among the auto-backups (if enabled)? Location of these files depends on your OS.

Have you tried some data recovery software? You can use the Google search tool in this regard. .My Mac Book Pro hard drive has crashed and I’m in the process of replacing it. However, I had a lot of important data on that hard drive that he needs recovered. Then I found uFlysoft data recovery software that recovers data from corrupt/bad hard drives. And fully supported for NTFS/FAT32 mac files.

Maybe you can try uFlysoft Data Recovery for Mac, it can recover LOST DATA on Mac only in three steps:
Step 1. Launch the software to scan the device where your files deleted
Step 2: Preview the scan result files and make mark if it is the one you find
Step 3: Recover files

The .ods file used in LibreOffice is in fact a version of a zip older containing various files. I am not an expert in the precise files involved. If you rename a .ods file to .zip and examine it with a package manager you will see a set of .xml files like (content.xml, meta.xml, mimetype, settings.xml, styles.xml) together with manifest.rdf, mimetype, META.INf etc. I wonder if the complete folder has been recovered, if so you could try renaming a copy to .ods and then try LibreOffice again. Worth a go… Peter

genious! It worked perfectly!

Thank you Peter

Yes I already checked, the backup file is empty (but I have learned my lession so “auto-backup” for the rest of my life!)