Red underlined words in some Calc cells but not a spelling issue


LibreOffice (same in older versions). English Language GUI. Windows 10.
Standard module for German language is installed and the spelling seems to work (more or less good).
Cells language is German(Germany).

In some cells with German text many/most words are underlined red even if they are correctly written.

Right mouse button click into the cell acts strange. Sometimes a popup appear and sometimes not.

Double click into the cell and all red underlines disappear first.
Change the focus to other cell and the red underlines appear again.

Double click into the cell and all red underlines disappear first.
Right click on one of the previously red underlined words and if the popup appear (no suggestions), close it again (left click somewhere else).
Then the complete cell still be without any underlines and looks fine!
Until the file is closed (also saved) and reopened again.
Then the words are underlined again ad I can perform the trick again.
It is just ugly!

Could it be because there is no grammar checking for German available?
In “Language Settings” in “Available Language Modules” and “Edit” there is Spelling checked box but there is nothing to check under “Grammar”.
In “Options” “Check grammar as you type” is disabled/unchecked.
Lists only an extra tool for German grammar.
I actually do not want to check the German grammar or install additional tool I do not need.

Any idea how to disable this red underlining?

Do the wiggly lines disappear when you switch off Tools → Automatic Spell Checking (Shift+F7)?


Cells language is German(Germany).

do you refer to the cell’s number format language, or the cell’s font language? Only the latter is relevant for spell-checking. And there is no grammar checking in Calc (that would be blue underlined in Writer), only spell checking.

Yes, if I deactivate the Automatic Spell Checking these wiggly lines disappear, but it is not really my intention. I’d like to have the spell check enabled.
No, it is not number format only, it is language, visible in “Format Cells” as Language value and also in the low bar with sheet numbering etc.
Good to know that grammar is blue not red.

So it is kind of a spelling issue which seem not to work properly for which reasons ever.

This file was an .ods one from the start?

There are cells with both English and German text? Edit the cell and see menu Format - Character… - Font tab - Language:. It could be that cell language is set to German but partial cell content (character) is set to English.

This is the expected behaviour if the cell content is only one word.

Default languages for documents (menu Tools - Options… - Language Settings - Languages) show “ab” with a green mark below for German?

Is the Status bar, and there is shown the document language.

Would you share a reduced sample of your file? To do that, edit you question and use the upload icon. Thanks.

Edit: There is copy & paste from different language documents/cells/cell content?

Yes it was.

Looks like all are German

Yes, it is

I think I’ve found the root cause: “Line break” in a cell.
See attached file.
A1: no line breaks. All fine.
A2: one line break. Wiggly lines are back.
A3: several line breaks. Wiggly lines are back.

I’ve tried the same with “English (USA)” without any issues.
Seems to be a language specific issue.

Untitled 1.ods (9.6 KB)

Yes. There is a bug report tdf#140152. Also includes manual formatting.

Nice to know that there have been no solution for 8 months already.