Regular Expressions is not working on Mac

On ubuntu with Libreoffice I often use this two regular expressions:

To Identify opening quotation marks


To identify closing quotation marks


However, recently I installed the latest Libreoffice on my Mac. this two are stop working properly, they only find quotation marks rather than identifying the opening or closing.

My Mac is on an old imac intel core duo with OS X 10.6.8

Is it something to do with the Java environment.

ps:, on same mac, I used to use this to identify the uppercase words, (two caps together)


It worked fine, but today it stop working. Dunno why, I make sure it is only Regular Expression is on and other are off. but still no result.

@qubit1 thanks for your answer, I have summited the bug. Furthermore, I experienced the same problem in the latest OpenOffice. I made a video demonstration here:

@shiyuan, Cool, thanks for submitting the bug. What’s the bug # or url? It’s very helpful to keep the bug report linked to this question.

@qubit1 sorry, I tried to comment on this post few times, but however my Chrome is not behaving as it supposes to be. the bug is 60905. the URL is

@qubit1 may it be possible that on mac there is a different type of regex engine? found this:

@jorendc – If you have the time, please try to repro fdo#60905. Thanks!

@qubit1: done :slight_smile:

Hmmm…very suspicious!

There is a new Regexp engine in LO 4.0, so that might be the root of this issue:

From the docs of the new engine, “ICU Regular Expressions conform to Unicode Technical Standard #18, although I’m not sure if the old Regexp engine conformed to that spec or not!

It can’t hurt to file a bug report and provide as much information as possible. At the very least, we should probably provide some kind of warning or compatibility layer.

If you do file a bug, please post a link to it in a comment below using the format “fdo#123456”. And please let me know what they say about regexp compatibility – it would be helpful when these types of questions arise!


Bug has been filed: fdo#60905 has current status of NEEDINFO.

Resolving Question as BUG FILED.