Relative path changed to absolute on save


I want to store local files path with hyperlinks in calc. When I create an hyperlink I can write a relative path and it works. As soon as I close Calc and re-open the file, the links are “transformed” into absolute path. Is there a way to avoid this behaviour?


Save URLs relative to file system

Have you tried to move?
Writer only shows absolute path of destinaton, but uses relative path.

I tried to uncheck “Save URL relative to File System” but of course it did not work (my URL wasn’t saved anymore).

Yes moved my ods and my file and it does not work : File not found at “old URL”

Please upload and attach a sample document to your question with only one such hyperlink where that happens, and please tell us how you create hyperlinks, so far we don’t even know that and what it should look like and what it does look like instead. And your LibreOffice version and operating system. We assume you save in .ods LibreOffice’s default native ODF file format.

file2.ods (10.2 KB)
file1.ods (10.1 KB)

fails with option “save relative URLs”

Works fine for me
Version: (X86_64) / LibreOffice Community
Build ID: 433d9c2ded56988e8a90e6b2e771ee4e6a5ab2ba
CPU threads: 16; OS: Windows 10.0 Build 22631; UI render: Skia/Raster; VCL: win Locale: es-ES (es_ES); UI: en-US Calc: CL threaded

Yesterday I created the 2 files on Windows. Today I download them to /tmp/test/ on Linux. Clicking any of the two hyperlink gives
Bildschirmfoto von 2024-05-29 11-28-18

Version: (X86_64) / LibreOffice Community
Build ID: 433d9c2ded56988e8a90e6b2e771ee4e6a5ab2ba
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: x11
Locale: en-AU (de_DE.UTF-8); UI: en-US
Calc: threaded

Here is a video clip I made reproducing the issue from a new ods file:

Indeed, something’s broken there, apparently for longer already (tried back to 7.4.7).

tdf#159768 looks related and versioned to 7.3.7

I update my files with HYPERLINK

A workaround would be to use a cell formula


I don’t see this function (HYPERLINK()) in

See Spreadsheet Functions.
If you are using a non-English UI, function names may have been translated, either switch the Language in that online help page, or switch your function names to English under Tools → Options → Calc → Formula, Formula Options, Use English function names.

Thank you!