Remove a hyperlink in Writer - Linux

I’m working with Writer file where is a sentence with hyperlink and I try to get rid of the link. Nothing happens when I paint the link and…

  1. keyboard: Control+M
  2. mouse: right-klick and then choose “Clear Direct Formatting” (Poista suora muotoilu)
  3. toolbar: klick hyperlink icon and remove the whole hyperlink path (after this “Use” and “Close” buttons)

What is the right method?

LibreOffice is version and my operating system is Linux Fedora 17.

LibreOffice (WindowsXP): Shift+F10 → Poista hyperlinkki

“Shift+F10 → Poista hyperlinkki” works. Thanks a lot.

LibereOffice Writer in Finnish looks different. Is it possible that I have some old Writer version instead of Just words has changed to Finnish?

Is Control+M working with others?

This is Menu “Format - here you can determine the format of different object, but you can’t remove or edit hyperlinks. To edit them, use Menu “Edit; to delete them, use the context menu (right mouse click on hyperlink). Removing direct formatting (CTRL+M) doen’t help here.

BTW: You can install multiple languages for the user interface (localizations); how to install them depends on your OS. Once installed, you can toggle between them using Menu “Tools” → “Options” → “Language Settings” → “Languages” → “User Interface”.

Okay in case someone was like me and was thinking that hyperlinks and pictures that are links are the same thing… with LO they are not… and so to remove a link from a picture you must go to Edit->Links … then just remove the links! It was so simple yet I was frustrated because when I right click I never saw anything saying remove hyperlink on the pictures…