Remove inverted comma


Myself Hardik, I am new to linux used microsoft excel for many years.

I am not able to remove (’) apostrophe sign from dates mentioned in my column.

In Excel we used to just select the column and press (ctrl h) then write (’) in find and (blank) in replace then remove all.

Here i am not able to find and replace (’) apostrophe sign in database . please help. This is most useful command for me

Thanks in advance.

You can select the column and click Data > Text to Columns and click OK. Your text dates should become number dates. Just make sure you don’t have any separators selected that also appear in your column.

Until that came available, I used to use the find and replace below:

  1. Select the column in which the digits are found in text format. Set the cell format in that column as “Number”.
  2. Choose Edit - Find & Replace.
  3. In the Search for box, enter ^.
  4. In the Replace with box, enter &
  5. Check Regular expressions.
  6. Check Current selection only.
  7. Click Replace All.

Wow . Very helpful. both way worked. Many Many Thanks…

See also this FAQ.

The apostrophe is shown as a signal: Your Date was not recognized as Date, but imported as Text.

The best solution is to avoid this during import, and select the appropiate type for the column and the details, as 02.04.20 can be April second or 4th of February and also April, 20th of 2002 may be possible.

The usual solution is to select the column or range and use Text-in-columns from the Data-menu instead.
You select the type of the column by click on the head of the columns in the import grid shown.
There is also an option detect-special numbers.